Home>Support>Page Builder Interaction with “Insert Pages” Plugin

Page Builder Interaction with “Insert Pages” Plugin

Hi all,

The recent update to Page Builder 2.29.16 broke my page layout.

Background: I have Posts of different categories (e.g. Workshops, Shows), which themselves are based on Page Builder Layouts containing numerous widgets, among them Custom HTML Widgets. These posts are then included on the main Pages inside Page Builder Layouts using the Insert Page plugin.

With Page Builder 2.29.16 the Custom HTML content (included using Insert Page) is now shown unrendered, i.e. the visitors are seeing html code depicted as plain text (e.g. …) which was previously rendered as the respective div layout.

Reverting to 2.29.15 fixed the issue.

Kind regards,
Chris

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 2 months, 7 days ago Andrew Misplon
    Hi, I Work Here

    Hi Chris

    Thanks for posting your question.

    I have a demo source page seen here and a demo destination page seen here. If you can perhaps let us know what further steps need to be added to recreate the issue; we’ll give it a go and take it from there.

  2. 2 months, 7 days ago chris_munich

    Hi Andrew,

    Thank you for the quick reply and for looking into this. The source in my case is a post with the custom html widget and some div layout content. The destination is a page with pagebuilder layout. The plugin that I use to insert the content is Insert Pages.

    I am happy to pm you a testpage and screenshots from a site where I am running the affected 2.29.16 version, but I could not immediately find a way to send private messages on this forum. You may also contact me under the email registered for this account so that I can reply with all of the above.

    Thanks and kind regards,
    Chris

  3. 2 months, 7 days ago Andrew Misplon
    Hi, I Work Here

    Hi Chris

    Thanks for the update.

    The screenshots linked above are a test setup with Insert Pages. The test setup includes an Insert Pages shortcode in the source page with HTML. I’m not yet able to reproduce the described issue.

    You can export your source and destination pages by clicking on LayoutsImport/ExportDownload Layout within each page. You can upload the JSON files to WeTransfer.com or any online location and share the link here. If you’d like to move over to email support, please consider our SiteOrigin Premium offering.

  4. 2 months, 7 days ago chris_munich

    Hi Andrew,

    Please find the requested json files alongside detailed screenshots here: https://we.tl/t-mLpOS1wkWZ

    I have just reproduced the issue in a completely fresh WordPress Version 6.5.3 installation (running on PHP 8.2) with only ‘Page Builder by SiteOrigin’ Version 2.29.16 and ‘Insert Pages’ Version 3.8.1 installed.

    If you need further assistance, feel free to contact me for login details to my testpage, which I’m happy to share privately.

    Kind regards,
    Chris

  5. 2 months, 7 days ago Alex S
    Hi, I Work Here

    Hi Chris,

    I’ve investigated this issue and identified what’s going on. This issue is linked to the “Modern” Insert Method Insert Pages offers. Our previous compatibility was due to our fallback shortcode allowing HTML. We’ve had to prevent that, and that’s why you’re seeing HTML being output a text.

    I explored the possibility of adding compatibility for that mode, but I’m not able to access enough information during the rendering process to be able to do that reliably.

    Instead, I recommend adjusting the Insert Method setting. Please navigate to SettingsInsert Pages and set Insert method to Use legacy method. Save. How does that look?

    Kind regards,
    Alex

  6. 2 months, 7 days ago chris_munich

    Thank you Alex, the legacy setting works on my test page. On our main page, we are still expecting many visitors for another week until our biggest events for the year are concluded, so I will postpone testing it with the complex layouts there and remain on 2.29.15 until then. I will get back to you in circa 7 days on how your solution performs in the real world setting. Thank you very much for now.

  7. 2 months, 6 days ago Andrew Misplon
    Hi, I Work Here

    Hi Chris

    Thanks for the feedback; I’m glad to hear the legacy setting works. I’m going to close this thread for the moment. Please, let us know how you get on in a week when you have a gap to upgrade again.

    Chat then, cheers!

    Andrew

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More