Home>Support>Conflict with plugin Page Builder by SiteOrigin

Conflict with plugin Page Builder by SiteOrigin

Website: indofrenchhub.com
Theme: SiteOrigin CorpVersion: 1.20.2
Page Builder by SiteOrigin Version 2.29.5

This morning the website stopped working.
Shifted the site to a staging site (provided by the Hosting Service Provider) https://indofrenchhub.staging.tempurl.host/
All plugins were deactivated and the website was working.

Then 1 by 1 – activated the plugins until activating Page Builder by SiteOrigin and the website again stopped working.

Please help.

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 3 months, 16 days ago Andrew Misplon
    Hi, I Work Here

    Hi, thanks for posting your question.

    When you have a moment, please let us know what happened when the website stopped working; what did you observe? Was there a particular part of the site that stopped working? We’ll do our best to advise once we know a bit more.

    Kind regards

    Andrew

  2. 3 months, 16 days ago Indo French Hub

    Hi Andrew

    When the plugin is activated the Home Page https://indofrenchhub.com/ shows a blank page.
    Just updated the plugin ‘Page Builder by SiteOrigin’ to Version 2.29.6, however, the problem still exists.

    Some of the other URLs example https://indofrenchhub.com/learnfrenchonline also showed a blank page
    however, https://indofrenchhub.com/educational-trips/ , https://indofrenchhub.com/teacher-training/ were working even when the Plugin was activated.

    Currently, the Plugin is deactivated.

    Regards

  3. 3 months, 16 days ago Andrew Misplon
    Hi, I Work Here

    Thanks for those details. Page Builder seems activated at the moment. Perhaps I’m looking at a cached view. Is the white screen occurring on the site front-end or in the admin?

  4. 3 months, 16 days ago Indo French Hub

    No, Page Builder by SiteOrigin is currently deactivated.

    The white screen appears only on the site front-end.
    Admin, Dashboard, etc are working fine.
    Checked with the hosting support – who also confirmed the same.

  5. 3 months, 16 days ago Andrew Misplon
    Hi, I Work Here

    Thanks. A white screen could have several causes. If you can enable debugging and debug logging, you can check the debug.log file and find the exact issue. Here is how: Page: Debugging in WordPress.

  6. 3 months, 16 days ago Indo French Hub

    below is the relevant transcript of the chat with Hosting Support team…

    +++
    Abdul Wajed (agent)
    03-04-2024 12:46pm
    The server is not down and up and running
    https://indofrenchhub.com/wp-login.php
    https://wpmudev.com/hub2/site/2450822/hosting/analytics Front end
    of the site giving blank page, I am checking further, please allow me
    5-10 mins while I am working on it.

    Abdul Wajed (agent)
    03-04-2024 12:52pm
    As WP is fine, Can you please grant support access to your website,
    so I can check further regarding this?

    Abdul Wajed (agent)
    03-04-2024 12:55pm
    Looks like few pages have issues, others working fine like:
    https://indofrenchhub.com/enquiry-form/ Please allow me 5-10 mins
    while I am checking further and working.
    Indo French Hub – [email protected] (you)
    03-04-2024 12:55pmok
    Abdul Wajed (agent)
    03-04-2024 1:02pm
    Nothing in the console log but surely seems a plugin or theme
    causing the issue. I am setting staging and will try to narrow down the
    issue on staging.
    https://wpmudev.com/hub2/site/2450822/hosting/staging

    Abdul Wajed (agent)
    03-04-2024 1:12pm
    Surly one of the plugin is causing the issue, just a few mins more, I
    am still working on this.

    Abdul Wajed (agent)
    03-04-2024 1:28pm
    Almost done with my test, just allow me 5 mins more.

    Abdul Wajed (agent)
    03-04-2024 1:41pm
    No, those 2 are not causing the issue but plugins for sure, on staging
    you can see now just 4 plugins active and site is working fine:

    Abdul Wajed (agent)
    03-04-2024 1:42pm
    So, on staging do a full conflict test, and activate the remaining
    plugins one by one until you find the culprit.

    Abdul Wajed (agent)
    03-04-2024 1:44pm
    Hope you can take care of it from here.
    Indo French Hub – [email protected] (you)
    03-04-2024 1:44pm
    the plugins will have to be added one by one?

    Abdul Wajed (agent)
    03-04-2024 1:45pm
    No, just activate them one by one and check, all plugins are there but
    inactivated. https://indofrenchhub.staging.tempurl.host/wpadmin/plugins.php?plugin_status=inactive
    Indo French Hub – [email protected] (you)
    03-04-2024 1:45pm
    ok
    Abdul Wajed (agent)
    03-04-2024 1:46pm
    Hope this helps and you can take care of it.
    Indo French Hub – [email protected] (you)
    03-04-2024 1:46pm
    i am trying now
    Abdul Wajed (agent)
    03-04-2024 1:47pm
    Ok, It will take some time, if you don’t mind I need an urgent break,
    once done and if you need any further help, can you just open a new
    chat and we will help further if needed.
    ++++

  7. 3 months, 16 days ago Indo French Hub

    2nd chat

    +++
    Amir Ali (agent)
    03-04-2024 2:07pm
    Meanwhile, let me check on my side if I can find any firewall blockage

    Amir Ali (agent)
    03-04-2024 2:09pm
    I have checked the firewall and logs of the site but I there is no log
    related with the problem facing at the site

    Amir Ali (agent)
    03-04-2024 2:15pm
    I deactivated the WAF firewall for testing purposes but no luck. So,
    there is no blockage from our side Also, there is no console error from
    the frontend in Inspect tool and no log error from the Hub

    Amir Ali (agent)
    03-04-2024 2:15pm
    I am afraid you have to wait for the response of SiteOrigin to find how
    to solve the issue

    Indo French Hub – [email protected] (you)
    03-04-2024 2:15pm
    ill deactivate that plugin now on the main website also

    Indo French Hub – [email protected] (you)
    03-04-2024 2:19pm
    ok its working with a few formatting issues which is probably because
    the page builder is deactivated
    Amir Ali (agent)
    03-04-2024 2:19pm
    Yes. The page is working at my end as well

    Amir Ali (agent)
    03-04-2024 2:19pm
    The issue was with just home page and other pages were operational
    before when using the page builder

    Amir Ali (agent)
    03-04-2024 2:22pm
    The SiteOrigin can provide you a solution on how to solve the issue of
    home page and if you need any thing else from us, you can come
    again anytime. We are available 24/7 to provide assistance
    +++

  8. 3 months, 16 days ago Alex S
    Hi, I Work Here

    Hi,

    Thank you for the chatlog. As Andrew mentioned, a white screen is a sign of a PHP error. By default, WordPress hides this so we’re not able to tell what’s going on. To work towards resolving this issue, we need to know the specific PHP. To see the PHP error you’ll need to Debugging in WordPress rel=”ugc”>edit your wp-config.php and enable error logging in WordPress. Your hosting provider can help you with making this change.

    Kind regards,
    Alex

  9. 3 months, 16 days ago Indo French Hub

    3rd chat

    Indo French Hub – [email protected] (you)
    03-06-2024 4:31pm
    did you see SiteOrigin debugging guide
    Page: Debugging in WordPress

    Indo French Hub – [email protected] (you)
    03-06-2024 4:32pm
    anything to be done about that?

    Amir Ali (agent)
    03-06-2024 4:36pm
    The debugging guide just tells how to activate the debug mode
    nothing else. You can see the hosting logs for this purpose.
    https://wpmudev.com/hub2/site/2450822/hosting/logs

    Amir Ali (agent)
    03-06-2024 4:37pm
    Just to confirm, do you inform SiteOrigin support that just the
    homepage is not operational?

    Indo French Hub – [email protected] (you)
    03-06-2024 4:37pm
    yes

  10. 3 months, 16 days ago Alex S
    Hi, I Work Here

    Hi,

    Thank you for the additional chat. Unfortunately, we’re not able to view https://wpmudev.com/hub2/site/2450822/hosting/logs. Can you please view that page while logged in, and then paste it into a Pastebin. Reply with a link to the Pastebin.

    Kind regards,
    Alex

  11. 3 months, 16 days ago Indo French Hub

    Have downloaded the log from the hosting site…

    WPMU DEV
    Your log export for indofrenchhub.com
    You can download your exported log files for indofrenchhub.com here:
    https://s3-eu-west-1.amazonaws.com/wpmudev-hosting-eu/indofrenchhub/indofrenchhub.wpmudev.host-log-export-2024-03-06-hmzfkvezohxmyhis.zip

    This download link will expire in one week.

  12. 3 months, 16 days ago Andrew Misplon
    Hi, I Work Here

    Thanks. I’m not seeing anything helpful in php_errors.log at the moment. When you have a moment, please try testing the home page with all plugins temporarily deactivated except for Page Builder. Does the issue persist? In conjunction with this test you can also send us the home page layout by editing the page and clicking Layouts > Import/Export > Download Layout. The JSON file can be uploaded to WeTransfer or Dropbox and the link posted here.

  13. 3 months, 16 days ago Indo French Hub

    Hi Andrew
    Please refer the chat with the Hosting Support team…

    +++
    Hi Indo French Hub

    Thank you :)

    Please check staging site – it should be working now. I left Page Builder active and the homepage is loading. I noticed some small issues still happening but they are entirely different thing and are related to JS/CSS optimization on site – so if you need assistance with this, please start a separate support ticket about it.

    As for this issue:

    1. Initially I couldn’t see any errors related to SiteOrigina because of a “flood” of deprecation notifications related to All-in-One Events Calendar. Deprecation notices aren’t bugs/errors – they are just notifications for developers to be considered during future development so it’s fine to ignore them for now. However, I had to temporarily disable the plugin to “uncover” actual error.

    2. Then the error started showing up:

    PHP Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /var/web/staging/public_html/wp-content/plugins/siteorigin-panels/inc/renderer.php:955

    with Stack Trace containing this

    /var/web/staging/public_html/wp-content/plugins/siteorigin-panels/inc/renderer.php(71): SiteOrigin_Panels_Renderer->get_panels_layout_data(‘s:254669:”a:3:{…’)
    /var/web/staging/public_html/wp-content/plugins/siteorigin-panels/siteorigin-panels.php(533): SiteOrigin_Panels_Renderer->generate_css(95961)
    A look into plugin code shows that the 95961 number here is correct behavior and it’s just a page ID (as in DB) but this specific part

    get_panels_layout_data(‘s:254669:”a:3:{…’)

    was not right. Code shows that function expects an array of data to be passed to it but it gets a string. That string looks like a serialized version of array – so the way such data is usually stored in the DB – that was not properly decoded (unserialized) before being passed over to that code.

    3. So I checked DB and compared a few other (working) posts data – specifically the “panels_data” post meta field value.

    I noticed that for this particular page that serialized data is actually “broken”. I confirmed that using online tools for decoding it (unserializaing). A closer look showed that it had this prepended

    s:254681:”s:254669:”

    and this appended at the end

    “;”;

    That was breaking serialized array (they are very “fragile”), thus making it impossible to be decodede/userialized before being used in the Page Builder.

    All in all, that resulted in the issue.

    I’ve fixed that data on the staging site directly in the DB, then purged Hummingbird’s cache and that fixed the issue.

    —————–

    As for “why” – I’m honestly not sure and I’m not able to tell why that data got “messed up” this way. My best best here would be that either there was an update done from some very old version of PageBuilder (or one of its related plugins) and it just didn’t went entirely well or there was some unexpected temporary glitch. Maybe SiteOrigin would have better ideas on why this happened…

    —-

    For now, I only did the change on the staging site. For any changes on live site, we need your explicit permission – including you being aware that we’d make additional backup before that and restore it in case anything goes wrong.

    Best regards,
    Adam

    +++
    Hi Adam,
    That looked like some serious R&D! Most of it went over my head of course.
    I checked the HomePage on the staging site, but it is not displaying all the elements correctly.

    Let me run this with SIteOrigin first and come back to you on their response.

    +++

  14. 3 months, 16 days ago Indo French Hub

    Here is the JSON file

    https://we.tl/t-XHJ3OdQK5c

  15. 3 months, 16 days ago Indo French Hub

    Here is the JSON file from the staging website
    https://indofrenchhub.staging.tempurl.host/

    https://we.tl/t-XHJ3OdQK5c

  16. 3 months, 16 days ago Andrew Misplon
    Hi, I Work Here

    Hi. The only time I’ve encountered serialized data corruption is due to database migrations done in a way that doesn’t support serialized data. If the page data is corrupted, the only way to recover is to rollback the page to a revision that isn’t corrupted or fix the data as your hosts have offered.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More