Home>Support>conflict between Page Builder & polylang plug-in

conflict between Page Builder & polylang plug-in

Hello,

I’m using: Vantage Premium theme + Page Builder 2.1.2 + Polylang 1.7.6 + WP 4.2.2.
The site is in Polish (PL) and I’m working on Deutsch (DE) version using Polylang and it is almost done.
I admire Page Builder. After updating of PB I found that content created with Page Builder in Polish now is in Deutsch. However the content of Header, Sidebar and Footer is still in PL. But in Header, Sidebar and Footer I’m not using Page Builder.
After deactivating Page Builder I found my lost polish version. But I want to enjoy of the possibilities of PB :), so PB is active and languages are mixed in Polish version.
I’ve read threads in Support and I deacitvated Custom Fields in Languages/Settings but it doesn’t help.
Home page is in Polish because I’ve changed it (and the current Home DE version also is in PL, temporarily I hope).
Would you be so kind to help me to find solution?
Kind regards,
Ewa

URL: http://www.doormaster.pl/sbr-120-brama-rolowana-stalowa/

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 6 years, 5 months ago Andrew Misplon Hi, I Work Here

    Hi Ewa

    It’s been a little while since I looked into this. If you have the link of the thread you read mentioning Custom Fields in Languages/Settings, please, send it to me so I can catch up. We’re at GMT+2 so I’ll only be able to start on this tomorrow. I’ll do local testing and try figure out where the problem is.

    WPML works with Page Builder but we do need a free translation plugin that is compatible. Polylang is our best option at the moment. Hopefully we can resolve! Chat tomorrow.

  2. 6 years, 5 months ago webEwa

    Hi Andrew,

    Thank you for quick reply.
    Here is mentioned thread: Thread: Conflict btw Polylang and PageBuilder
    “(…)At Settings > Languages > Settings > Synchronization there is a checkbox for Custom Fields. Page Builder data is stored in a custom field. I de-activated this setting and behaviour now appears to be normal. I can edit a linked page without the contents being updated on the other linked page. (…)
    But it is not a solution in my case…

    Good night,
    E.

  3. 6 years, 5 months ago Private Message - webEwa

    This is a private message.

  4. 6 years, 5 months ago Andrew Misplon Hi, I Work Here

    Apologies for the delay Ewa. All seems normal in my local testing. If possible, please provide login details so we can take a look. I’ll send instructions shortly. Thanks.

  5. 6 years, 5 months ago Andrew Misplon Hi, I Work Here

    Hi WebEwa

    Would it be possible for you to create a temporary admin account for us so we can log in and take a look? You can create the account with the following email address:

    [email protected]

    Just navigate to Users > Add New in your WordPress admin. Enter siteorigin for the username and [email protected] for the email address. Make sure you’ve selected Administrator for the role and enabled the “Send Password” field so we receive the details.

    Once we’re finished taking a look, you can delete this account. We’ll let you know when to do that.

  6. 6 years, 5 months ago webEwa

    Hi Andrew,

    Thank you for your answer. I've send you data with temporary admin account.

    As I've mentioned before only home pages and pages with products have
    PL/DE translations. However I manually corrected main page in PL and
    ABR-55 into Polish, so they looked as OK, but their DE versions are also in Polish (these parts where is used Page Builder).

    Sidebar, footer and header are OK.

    Sorry for my late response, but I've been on holidays without access to the Internet.

  7. 6 years, 5 months ago Andrew Misplon Hi, I Work Here

    Thanks for your feedback. I’ve asked Greg to check our Spam folder for us. Unfortunately, the user email didn’t come through to the thread. If possible, please post the username and password making use of the Private Reply checkbox below.

  8. 6 years, 5 months ago Private Message - webEwa

    This is a private message.

  9. 6 years, 5 months ago Andrew Misplon Hi, I Work Here

    Thanks :)

  10. 6 years, 5 months ago Andrew Misplon Hi, I Work Here

    To try setup a baseline could you check these two pages:

    http://www.doormaster.pl/test-page-polish/
    http://www.doormaster.pl/de/my-german-test-page-2/

    They are linked and seem to have editable content that isn’t being mirrored. Can you please confirm that those two pages work OK on your side in terms of translation etc.

  11. 6 years, 5 months ago webEwa

    Thank you very much!

    It works on the tested pages, which you created as well as on the product pages!
    I’ve change content of the PL page ABR-55S and it doesn’t change the content of the DE page ABR-55S.

    So, shall I now to change manually all mixed content?
    Was it my mistake in settings or somewhere else? I would like to prevent the same problem for the future, that’s why I’m asking :).

    Kind regards,
    Ewa

  12. 6 years, 5 months ago Andrew Misplon Hi, I Work Here

    I’m afraid I don’t have that much time using Polylang and am not quite sure what happened with those pages.

    Can you perhaps try:

    Create two new pages:

    ABR-55S Polish Clone
    ABR-55 Dutch Clone

    Now you have two new blank pages named as above. On each page in Page Builder click the Prebuilt button and clone the original page.

    With your two copies ready, set the default lang of each and link them using the Polylang metabox on the right of the page.

    Now that they are duplicated and linked, does the issue still persist?

    I’m basically saying, create a complete duplicate of these two pages and their link. Then see if the problem persists. If the problem resolves we can delete the originals and use these pages rather.

  13. 6 years, 5 months ago webEwa

    Many thanks, I will check the way you have proposed.
    Have a good day!
    Ewa

  14. 6 years, 5 months ago Andrew Misplon Hi, I Work Here

    Cool, thanks. Let me know how it goes.

  15. 4 years, 9 months ago Private Message - WordPress

    This is a private message.

  16. 4 years, 9 months ago Private Message - Seranli LI

    This is a private message.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More