Home>Support>Conflict btw Polylang and PageBuilder

Conflict btw Polylang and PageBuilder

Hi Andrew
We chat on another thread (https://siteorigin.com/thread/changes-are-also-visible-on-the-original-page/) and you asked me to open a new one.
I installed Polylang plugin. And it looks like there is a conflict between PageBuilder and Polylang : Changes are also visible on the original page. So when I create the english version of an article or a page, and make some changes on the content of it, it also changes the original version (the french version actually). The title are not impacted. So the english title of the article will still be in english, and the french title won’t change.
I have tried de inactivate PageBuilder plugin and both pages (french and english) are great. The french one in french, and the english one in english. That’s why I came to the conclusion the problem comes from PageBuilder. Sorry guys, this is on you now :(

I got another problem with the Polylang plugin, but, finally I guess this one isn’t on you ‘cos it remains when I inactivate PageBuilder plugin. So i’ll try to ask Polylang’s programmer about it (unless you got an idea. I told you about the problem on my previous thread).

Hope my english is not too bad and you can understand my problem.

Looking forward to hearing from you guys !

Thanks for your help.

Christophe

URL: http://www.stagecamera.fr

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 5 years, 3 months ago Andrew Misplon Hi, I Work Here

    Hi Christophe

    Thanks for helping us out with this new thread. We’re at GMT+2 so it’ll be best if I jump into this tomorrow with fresh eyes. Thanks for the further wait. I’ll be with you ASAP.

  2. 5 years, 3 months ago Andrew Misplon Hi, I Work Here

    Thanks for the wait Christophe. I’m all setup now but am not immediately seeing the same problem.

    I’ve got an English and Italian page running. I’ve cloned the English page on the Italian page and saved both. I’ve then made changes to only the English page. Those changes aren’t reflecting on the Italian page.

    If you’d like to help perhaps we could try a few tests:

    1. Does this happen when you create a new set of test pages, one English and one French?

    2. Does this happen if all other plugins are de-activated? Leave Page Builder, Polylang and perhaps Black Studio TinyMCE activated, de-activate all other plugins and re-test.

    3. What happens if you de-activate as in step 2 and then try create two new pages like in step 1?

    Thanks :)

  3. 5 years, 3 months ago Andrew Misplon Hi, I Work Here

    To confirm, I did my testing on pages not posts. Are you also testing on pages? Thanks.

  4. 5 years, 3 months ago ChristopheParis

    Hi Andrew,
    I’m sorry, I can’t work on it before the end of the afternoon.
    So, it you’re ok with it, we’ll work on it day after day ;-)
    Just for you to know, I already tested the step 2 & 3 : de-activate all plugins but Page Builder, Polylang and Black Studio TinyMCE : the problem remained on pages already created, and also when I tried do created 2 new pages.
    I’ll try the step 1 later !
    Thanks :-)

  5. 5 years, 3 months ago Andrew Misplon Hi, I Work Here

    Yeah sure, no rush.

    Mmm ok sounds like you’ve done step one already.

    Other things to check would be Dashboard > Updates, is everything up to date including WordPress?

    One last idea, try switching themes to a default theme like Twenty Fifteen, then run a test again.

    Chat later. Cheers.

  6. 5 years, 3 months ago ChristopheParis

    My version of WordPress is 4.1.1.
    I have not the last theme version ‘cos I don’t have a child theme :( Yeap, my bad. I didn’t know about that and I don’t know for now how to fix that without breaking what I have done !
    However, I have tried to switch on some other themes, like Twenty Fifteen, and I still have the problem. That’s why I guess it won’t help to update my theme. .

    But I just updated PageBuilder (I got 2.1 version now). And now I got 2 problems :
    – The changes on the english page are reflecting on the french page (and vice versa)
    – My page layout is broken :( I lost a lot of what I set.

  7. 5 years, 3 months ago ChristopheParis

    Hope you’ll be able to help me !
    Thanks a lot.
    Christophe

  8. 5 years, 3 months ago Andrew Misplon Hi, I Work Here

    Ok let’s start with the most urgent issue:

    My page layout is broken :( I lost a lot of what I set.

    Was this due to the page mirroring or something else?

  9. 5 years, 3 months ago Andrew Misplon Hi, I Work Here

    Could you perhaps create a temporary set of login details for us so we can take a look? Instructions below if that’s cool.

    Would it be possible for you to create a temporary admin account for us so we can log in and take a look? You can create the account with the following email address:

    [email protected]

    Just navigate to Users > Add New in your WordPress admin. Enter siteorigin for the username and [email protected] for the email address. Make sure you’ve selected Administrator for the role and enabled the “Send Password” field so we receive the details.

    Once we’re finished taking a look, you can delete this account. We’ll let you know when to do that.

  10. 5 years, 3 months ago Private Message - WordPress

    This is a private message.

  11. 5 years, 3 months ago ChristopheParis

    Hey Andrew
    Sorry for this late answer. I’m in a really busy week !
    I created an admin login for you. Thanks so much to have a look on it and to be so helpful.
    Do whatever you want on the website ! This url is for all my tests.
    Hope you’ll find the solution !
    I’ll send you an email to tell you more about my layout problems.
    Thanks !

  12. 5 years, 3 months ago Private Message - Christophe Averlan

    This is a private message.

  13. 5 years, 3 months ago ChristopheParis

    Hi Andrew
    How is it going ? do you find any solution ?
    Please keep me posted !
    Thanks !
    Christophe

  14. 5 years, 3 months ago Andrew Misplon Hi, I Work Here

    So sorry about the huge delay! Taking a look now.

  15. 5 years, 3 months ago Andrew Misplon Hi, I Work Here

    Thanks for the login details, that helped me dive into testing quickly. I think the problem is this. At Settings > Languages > Settings > Synchronization there is a checkbox for Custom Fields. Page Builder data is stored in a custom field. I de-activated this setting and behaviour now appears to be normal. I can edit a linked page without the contents being updated on the other linked page.

    Could you dive in next week and check it out…see if I’m right. I’m hoping that there aren’t any custom fields that you need to synchronised. That way you won’t mind de-activating this setting.

    Let me know how it goes. Thanks for all your effort on this.

  16. 4 years, 9 months ago Gustavo da Silva

    Hello,

    I had similar issue, and I found that it was because I sent 3 pages to the trash, and don’t delete they permanently. Then I created similar pages with exactly the same name. Apparently, Polylang gets crazy. I had to delete permanently all the documents from the trash and from pages, and also from the Lingotek cloud, and create they again. I was here looking for a solution, and saw your post.

    Gustavo

  17. 4 years, 9 months ago Gustavo da Silva

    Thank you Andrew, The problem comes again, and I did that you said, and works well.
    But I have problems translating my pages designed with Pagebuilder and Polylang. Polylang translate the content, not the PB design. Do you have any Idea about fixing this problem?

    Thank you!

  18. 4 years, 9 months ago Andrew Misplon Hi, I Work Here

    Hi Gustavo

    Thanks for your feedback regarding trashed pages and permalinks, that’s a top tip for sure! I’ll keep it in mind moving forward.

    If possible, please, open a new support thread for us: Page: New Thread. I’ll jump in ASAP tomorrow and find your thread if it’s been added.

    Thanks again.

  19. 4 years, 8 months ago moshefil

    Good day!
    I need help on my website are only two plug-ins. It’s all yours and Polilang. Change in one language leads to the exact change in the other language.
    In advance, I thank you.
    Moshe.

    • 4 years, 8 months ago Andrew Misplon Hi, I Work Here

      Hi @moshefil

      Go to Settings > Languages > Settings > Scroll down to Synchronization and disable Custom fields.

      For further help, please, open a new thread and then post the link to the new thread here.

      Thanks

  20. 4 years, 6 months ago greentree

    Hi all,

    stopping the synch seems to solve the problem for me as well, i.e. changes remain on the page they are entered. Thanks!

    Do I have to correct all wrongly synched pages now?

    My observation:
    1. http://domain.tld/wp-admin/post.php?post=29&action=edit shows the Pagebuilder view with 2 versions for 2 languages. This is OK.
    2. Now revert to the standard editor (“Switch to Editor”). The original texts, which do not get delivered in the FE, are still there!

    Any trick to “switch back” to these texts?

    :)
    Armin

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More