Home>Support>Bug / Problem with a another Program/Plugin (RankMath)

Bug / Problem with a another Program/Plugin (RankMath)

Hello.
Unfortunately, my English is very poor – sorry, please.

I have a bug in the SiteOrigin PageBuilder.

I’ve had your plugin for a long time (pagebuildger widgets and css) .. everything worked so far. now this error has occurred.

The guys from rankmath recommend me to contact you – which i do with this.

wordpress, themes and all plugins are up to date.
—–
My SEO tool RankMath does not work correctly with this pagebuilder.

If the SiteOrigin Pagebuilder plugin is deactivated, everything goes!

When I the pagebuilder activated – the following error is:

The following is displayed in the RankMath plugin:
“Preview desktop” or “Preview mobile” problem:
No automatic update of the TITLE – and therefore no correct information in the sidebar for “SEO” (xx / 100) …

Current: Title is entered. Texts too. Site save. I work with the SiteOrigin Pagebuilder. It has been going well for a while – not now.

Currently I have to enter everything manually so that it works. that’s not good in the long run.

this is the case with all my domains. there are different themes – but always the problem with the Siteorigin PageBuilder.

As written, the error is only if the plugin siteorigin pagemaker is activated. With other Plugins / Pagebuilders it works.

could you talk to rankmath and solve the problem?

I also took screenshots and also a mini video about it. but can’t send it here.

Greeting
Frank

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 5 months, 7 days ago Andrew Misplon Hi, I Work Here

    Hi Frank

    Thanks for reaching out.

    Please, try a quick plugin conflict test. Does the issue persist if you temporarily deactivate all plugins except for Page Builder, the Widgets Bundle, and Rank Math. With only those plugins activated does the issue persist?

  2. 5 months, 7 days ago F. M.

    Hello Andrew,
    Thank you for your answer.

    yes – I had already tested that – with different themes. It’s still the problem.
    if I deactivate the plugin “siteorigin page builder” = with the classic editor it works.
    I reactivate the plugin “siteorigin page builder” = the problem comes back.

  3. 5 months, 7 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update.

    Please, try the following:

    * Temporarily deactivate all plugins except for Page Builder and Rank Math.
    * Edit a page and take a screenshot of the page as you see it.
    * Open the browser console and take a screenshot of the console. Here is how to open the browser console.
    * Please, upload both screenshots to Imgur.com or any sharing site like Dropbox and send us the link. We’ll take a look and go from there.

  4. 5 months, 7 days ago F. M.

    Hi Andrew,

    here is the downloadlink

    Private Snippet

  5. 5 months, 7 days ago F. M.

    please delete the link here in the forum after the download.

  6. 5 months, 6 days ago Andrew Misplon Hi, I Work Here

    Thanks for the files. I’ve marked the link as private so only you and SiteOrigin can see it. I’ve asked Alex here at SiteOrigin to take a look when he’s next online.

  7. 5 months, 5 days ago Alex S Hi, I Work Here

    Hi,

    Thank you for the videos and screenshots. I’ve run a few tests and I’m unable to replicate this. Here’s a video of me attempting the steps you took in your video.

    Can you please clarify what your Single Page Title is set to? You can check this by navigating to Rank MathTitle & Meta, open the Pages Post Type.

    Kind regards,
    Alex

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More