Home>Support>All Headers & Buttons dissapeared after PHP update

All Headers & Buttons dissapeared after PHP update

Hello Everybody,

After updating our website recently we discovered two major changes to our site.

All SiteOrigin ‘Hero’ and ‘Button’ widgets are not displayed. When I open PageBuilder, I can see & edit the Hero. But after saving, there is no Hero showing up on the page.

The same for all the buttons. I can add, edit/customize all the buttons in PageBuilder. But after saving, the button is showing up as a regular text. Not any design.

Example 1: Here I can adjust in Pagebuilder
Voorbeeld-Home

But it is not appearing on the site:
Voorbeeld-home-2

Example 2: Here I can adjust in Pagebuilder
Voorbeeld-Pagebuilder

But it is not appearing on the site:
Voorbeeld-welkom

Please let me know how to fix this problem!

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 15 days, 9 hours ago Andrew Misplon Hi, I Work Here

    Hi Sem

    Thanks for reaching out. You can try viewing your site’s front-end and checking for errors in the console. Errors will be printed in red text if present. Here is how to check https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis.

  2. 11 days, 10 hours ago Sem Beale

    Hi Andrew,

    Thanks for your reply. I checked some errors with the developer tool. But the errors don’t sound familiar.

    The 2 errors I get are:

    – Failed to set referrer policy: The value ” is not one of ‘no-referrer’, ‘no-referrer-when-downgrade’, ‘origin’, ‘origin-when-cross-origin’, ‘same-origin’, ‘strict-origin’, ‘strict-origin-when-cross-origin’, or ‘unsafe-url’. The referrer policy has been left unchanged.

    – Uncaught ReferenceError: u is not defined
    at d (:1:693)
    at :1:809
    at :1:814

    Does this ring a bell to you?

    Many thanks!

  3. 9 days, 16 hours ago Alex S Hi, I Work Here

    Hi Sem,

    The first notice, while not ideal, won’t result in this type of issue. The second error looks to be from a minified JavaScript file and is likely related to the issue you’re facing. WordPress 5.6 is a major update that includes an updated version of jQuery. If you’re using a plugin or theme that’s compatible with the newer version of jQuery a JavaScript error will occur and due to how SiteOrigin Hero widgets works, it won’t be able to display.

    Can you try disabling all non-SiteOrigin plugins and see if this fixes the issue? You’ll need to clear all your caches after disabling your plugins. This is not to suggest you’re facing a plugin conflict, only that this test will allow you to identify any plugins that could aren’t compatible with the newer version of jQuery.

    If it does fix the issue, then try re-enabling your plugins one by one until the issue comes back. This procedure will help diagnose which plugin is causing the issue.

    Once we know that, we’ll be able to look at what might be causing the conflict and either solve the problem or help you find an alternative plugin.

    If you aren’t using a SiteOrigin theme, then you can also try temporarily switching to one of the default WordPress themes to see if the issue is theme related.

    Kind regards,
    Alex

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More