Home>Support>Word Press language Plugin WPML is not translating pages

Word Press language Plugin WPML is not translating pages

By Seranli LI, 2 months ago. Last reply by Alex S, 2 months ago.

Hello SiteOrigin,

Firstly thank you and excellent job ob a product that is free yet, amazing. This makes me very willing to go premium and I will, indeed. You have no idea the headache I went through buying themes that do not work and trying free themes that are just rubbish. Your team deserves alot of thank yous and more.

My issue is with the Word Press WPML, I noticed there is no option to translate pages. I am in contact with the WPML team about my woes, but I also wanted to get intouch here. Is there a problem this theme has with WPML and translating pages, a known issue?

Thank for your time and keep up the good work.

This is a free community support forum. Replies are not guaranteed. If you need professional email support, please purchase a SiteOrigin Premium license.

  1. 2 months, 15 days ago Alex S Hi, I Work Here

    Hi Seranli,

    Thank you for the kind words! :)

    That’s odd, you should definitely be able to use WPML. To clarify, at what point are you unable to proceed in terms of setting up WPML and Vantage? As in, are you able to create duplicate versions of pages? Are you able to translate said duplicated pages? Are the translations just not appearing on the frontend?

    Are you trying to use WPML with SiteOrigin Page Builder? If so, give this article a read as it might help.

  2. 2 months, 15 days ago Seranli LI

    Hello Alex,

    The translation is just not showing up.

    I am now manually translating the pages, tedious but doable.

    Thanks for the article.

  3. 2 months, 15 days ago Alex S Hi, I Work Here

    Hi Seranli,

    To clarify, are you stating they’re not appearing on the frontend or on the backend?

    Would it be possible for you to create a temporary admin account for us so we can log in and take a look?

  4. 2 months, 15 days ago Private Message - Alex S Hi, I Work Here

    This is a private message.

  5. 2 months, 13 days ago Seranli LI

    Hello I created the user details and hope you received it.

  6. 2 months, 13 days ago Private Message - WordPress

    This is a private message.

  7. 2 months, 12 days ago Private Message - WordPress

    This is a private message.

  8. 2 months, 12 days ago Seranli LI

    Alex, I thought this was posted private.

    I had to change the setting please contact me if you are not able to login, which very well will be the case.

  9. 2 months, 12 days ago Alex S Hi, I Work Here

    Hi Seranli,

    Only posts that are marked as private are private – such as the WordPress emails – only you and staff can see those.

    Can you please provide me with the login details? Please select “Private Reply” on the bottom right of the comment box.

  10. 2 months, 11 days ago Seranli LI

    Hello Alex,

    I do not see a “private reply” selection on the bottom right of this reply box or on the entire screen.

    I would like to get several issues resolved with your help.

  11. 2 months, 11 days ago Private Message - Alex S Hi, I Work Here

    This is a private message.

  12. 2 months, 11 days ago Private Message - Seranli LI

    This is a private message.

  13. 2 months, 8 days ago Alex S Hi, I Work Here

    Hi Seranli,

    Sorry for the delay.

    Ah, I see what’s going on. You have two issues:

    You haven’t translated most of the pages. All bar a select few are correctly translated. Please give the following article a read for an idea of how to use WPML and SiteOrigin page Builder. Page: Using Page Builder with WPML

    An example of this is the about page. If you view the Turkish version while your language is set to the English version, you’ll be redirected (and vice versa).

    Now the second issue is that there’s a plugin conflict on your page which is preventing the drop down from working correctly (ie. preventing you from easily changing language to confirm the first point). Can you try disabling all non-SiteOrigin plugins (leave WPML active) and see if this fixes the issue? You’ll need to clear all your caches after disabling your plugins.

    If it does fix the issue, then try re-enabling your plugins one by one until the issue comes back. This procedure will help diagnose which plugin is causing the issue.

    Once we know that, we’ll be able to look at what might be causing the conflict and either solve the problem or help you find an alternative plugin.

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More