Home>Support>Why doesn’t copy/paste work for all widgets?

Why doesn’t copy/paste work for all widgets?

I appreciate the new copy/paste widgets functionality a lot! I notice that it does not work for all of my widgets–sometimes it is grayed out and I can’t copy widgets. I’m sure there is a good reason for this, but I’m curious what I should know about how this works.
I note that I can’t copy the following widgets (at least on the page I’m working on):

SiteOrigin Button
LiveMesh Grid
LiveMesh Posts Carousel
Layout Builder
Custom HTML

But I can copy Enhanced Text and BuddyPress Style Pack Latest Activity.

This is a free community support forum. Replies are not guaranteed. If you need professional email support, please purchase a SiteOrigin Premium license.

  1. 4 months, 17 days ago Alex S Hi, I Work Here

    Hi Lucas,

    That’s odd. I’m not too sure why you can’t copy those widgets – those widgets should definitely be able to be copied. To clarify, do you not have the option to copy them or does it just not get copied? What version of SiteOrigin Page Builder are you using?

  2. 4 months, 17 days ago Lucas Hilty

    I have the option to copy them but when I click on it the menu does not close so it appears to be “greyed out.” It’s hard to tell visually.
    But that was on Firefox. I just tested on Edge, and it worked fine. So it must have to do with the browser. I’m on FF Quantum 60.0.1.

  3. 4 months, 17 days ago Alex S Hi, I Work Here

    Hi Lucas,

    That’s odd. I just tried that version of FireFox and can’t seem to replicate it. Can you please send me a screenshot of the greyed out text? I ask because nothing should be appearing as greyed out. Please note that we’re currently unable to process attachments so you’ll need to upload the image to a third party image hosting site like Imgur or vgy.me.

    For reference, this is what I see in FireFox:

  4. 4 months, 16 days ago Lucas Hilty

    Alex,
    It isn’t visibly greyed out: https://prnt.sc/jrni4r But when I click on “Copy Widget,” nothing happens–the menu stays open and the widget is not copied.

  5. 4 months, 16 days ago Lucas Hilty

    (Sorry about using “greyed out” metaphorically in my earlier post.)

  6. 4 months, 16 days ago Alex S Hi, I Work Here

    Hi Lucas,

    Ah. That explains that – that’s okay mate, I was just worried that in itself was the issue.

    Would it be possible for you to create a temporary admin account for us so we can log in and take a look at your website? As we can’t replicate this issue on any of our test websites, I suspect this may be a website specific issue.

  7. 4 months, 16 days ago Private Message - Alex S Hi, I Work Here

    This is a private message.

  8. 4 months, 16 days ago Private Message - The Dock

    This is a private message.

  9. 4 months, 12 days ago Alex S Hi, I Work Here

    Hi Lucas,

    That’s odd. I’m unable to copy the highlighted widgets on your website regardless of browser.

    Can you try disabling all non-SiteOrigin plugins and see if this fixes the issue? You’ll need to clear all your caches after disabling your plugins.

    If it does fix the issue, then try re-enabling your plugins one by one until the issue comes back. This procedure will help diagnose which plugin is causing the issue.

    Once we know that, we’ll be able to look at what might be causing the conflict and either solve the problem or help you find an alternative plugin.

  10. 4 months, 9 days ago Lucas Hilty

    Hi, Alex.
    I will keep this in mind. I would like to troubleshoot this but at this point it means cloning the site to safely disable plugins, so I don’t think I will take the time for now. But I will keep it in mind.
    Thank you so much for your help!

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More