Home>Support>Visual editor broken

Visual editor broken

I recently migrated my website a local dev on my computer. All the content still looks great when browsing the site, but when I try to edit Page Builder pages in the backend all I see is unclickable text links in place of the normal buttons and layout for the Page Builder visual editor. Content of normal (non-Page Builder) WP pages can still be edited just like normal.

I’ve updated all plugins and WordPress to the latest. I also tried disabling all plugins except Page Builder. I’ve also tried in both Chrome and Firefox. None of these things worked.

I greatly appreciate any help you can offer.

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 9 days, 19 hours ago Andrew Misplon Hi, I Work Here

    Hi Travis

    Please, take a screenshot of the issue as you’re seeing it in the WordPress administrative area and upload it to imgur.com or similar and send us the link. We’ll take a look and advise from there.

    Thanks

  2. 9 days, 17 hours ago Travis Pederson

    Hi Andrew, here's a screenshot of what I see when I try to edit pages…
    https://prnt.sc/sldd67

  3. 9 days, 5 hours ago Andrew Misplon Hi, I Work Here

    Thanks.

    How was the site migrated?

    In order to migrate successfully, Page Builder requires a method that supports data serialization. Velvet Blues and Duplicator are two plugins that support serialization.

  4. 8 days, 18 hours ago Travis Pederson

    Ah, gotcha. I migrated with a WP plugin cashed Backup Buddy so that's likely the issue.

    Is there anything I can do to fix this? I don't have access to the original site anymore to do another backup.

    If not I should be able to just recreate the pages.

  5. 8 days, 5 hours ago Andrew Misplon Hi, I Work Here

    Thanks for the update. Redoing the migration is, unfortunately, the route that’s required to resolve the situation.

    Is Page Builder working normally on new pages?

  6. 6 days, 19 hours ago Travis Pederson

    No, it's the same issue when I try to make pages from scratch.

  7. 6 days, 6 hours ago Andrew Misplon Hi, I Work Here

    Try checking the console for errors, here is how https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis.

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More