Home>Support>upgrade to 5.4.2 – siteorigin stops working

upgrade to 5.4.2 – siteorigin stops working

Hello – upgraded to 5.4. 2 today – siteorigin page builder stopped working – site displays fine – siteorigin interface for posts pages gone – can’t edit or create new pages – disabled plugins and checked everything no luck

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Hi Brian

    Thanks for reaching out.

    Summary: Please, try expanding your conflict test to include your theme or check the browser console for errors. Full instructions below:

    The WordPress 5.5 update has caused many themes and plugins to produce JavaScript errors. Those errors will break anything else on the page that makes use of JavaScript like Page Builder. Try to find a working baseline as follows:

    1. Temporarily switch to the default theme Twenty Twenty.
    2. Temporarily deactivate all plugins not authored by SiteOrigin.

    In that state, does the issue resolve? If so, you can begin adding your theme and then plugins back, testing for the issue after each reactivation to locate the issue. Let us know how it goes.

    Alternatively, if you have a bit of a technical background, try checking the browser console when the issue occurs, here is how https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis. Are there errors in red text? If so, which theme or plugin is producing those errors?

  2. 1 month, 16 days ago Brian Stocker

    hello – sry it is upgrade to 5.5 – I have checked plugins no luck – also tried switching to several themes – no change – current theme is eduma

    thanks Brian

  3. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Thanks. Please, open the browser console when the issue occurs, if there are errors in red, please, take a screenshot, upload to imgur.com or similar and send us the link.

    https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

  4. 1 month, 16 days ago Brian Stocker

    ok hope this helps – many thanks — https://www.test-preparation.ca/SiteOrigin.jpg

  5. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Thanks. Where is jlsuggest.js being loaded from? Hover over “jlsuggest.js” to see the path. Is it being loaded by a theme or a plugin?

  6. 1 month, 16 days ago Brian Stocker

    second – https://www.test-preparation.ca/SiteOrigin2.jpg

  7. 1 month, 16 days ago Brian Stocker

    “jlsuggest.js” is from plugin SEO Ultimate – i have de activated – no difference

  8. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Please, could you take a screenshot of the same page with the console open with the Twenty Twenty theme activated and all plugins deactivated except for Page Builder?

  9. 1 month, 16 days ago Brian Stocker

    oK I went thru them all again – looks like plugin SEO Ultimate is the problem – I did test before disabled but i guess i didn’t empty cache – anyway seems to work now and will find a substitute plugin for SEO Ultimate – thanks again for you assistance

  10. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Awesome, I’m really glad to hear you’re making progress. I’m sure SEO Ultimate will resolve the problem in an update shortly.

    WP 5.5 removed jQuery Helper, this plugin adds it back https://wordpress.org/plugins/enable-jquery-migrate-helper/, that might work as a patch for this issue but I can’t be sure, it might be worth a try.

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More