Home>Support>TinyMCE problem after upgrade

TinyMCE problem after upgrade

I just upgraded to Version 2.6.3 the other day.
I use TinyMCE as my editor upgrade (not BlackTinyMCE).
Prior to the upgrade, when I was within the SiteOrigin Editor, I would have the TinyMCE editor available to me. Picking fonts, formatting, etc. Within TinyMCE, I also had a color picker.

Since the upgrade, it only shows the default Visual Editor. If I revert back from the page builder it returns to normal. It’s only within the SiteOrigin Editor that it doesn’t show up.

Having read through other common problems with the Visual Editor, I tried:
1) Java consolidation – No effect
2) Disabling all plugins (expect TinyMCE since that’s what we’re testing) – No effect
3) Same as 2, except disabling and reenabling TinyMCE

Just wondering what else I might try. I see lots of posts about BlackTinyMCE and it’s description seems to imply its built for widgets. Since TinyMCE worked previously for me for quite some some, I wouldn’t think I would have to switch.

Please let me know if anyone has any suggestions.


I have additional troubleshooting information.

I actually found a way to reproduce it that might help you track this down.
If I login using the initial admin for the site, it works as expected.
If I login using a new account which was created, and granted administrator rights, it doesn’t work. This new account was just created yesterday.

I did confirm that in the profile of the new admin user it was not set to “disable to visual editor”

This means that there is something else tied to a brand new user which prevents this from working.

Hopefully that will help you track it down.

This is a free community support forum. Replies are not guaranteed. If you need professional email support, please purchase a SiteOrigin Premium license.

  1. 5 days, 7 hours ago Alex S Hi, I Work Here

    Hi Dbachen,

    Unfortunately, the visual editor must be enabled for this TinyMCE functionality to work. I’m not too sure why your other account had it disabled by default (that’s not normal) but if this happens again, you need to navigate to WP AdminUsersYour Profile and untick Visual Editor.

  2. 5 days, 6 hours ago dbachen

    Hey Alex,

    You misread that.. it was not set to disabled. It was enabled properly. And if I used the regular part of the editor, and not SiteOrigin, it works as expected.

    Please revisit this problem with that additional clarity.. I’m happy to provide screenshots to show this to you.

  3. 5 days, 5 hours ago Alex S Hi, I Work Here

    Hi Dbachen,

    Just to confirm, are you stating that the SiteOrigin Editor widget only works as desired when Visual Editor is ticked? And that it breaks when it’s unticked? If so, that really shouldn’t be happening as the Visual Editor must be enabled (by unticking the Visual Editor setting – which enables the functionality, I know this may sound confusing, it’s a really poorly labeled setting).

  4. 5 days, 3 hours ago dbachen

    What I’m saying is that:
    1) The box is unticked (it was never ticked)
    2) When I’m logged on as the original admin user everything works as expected
    3) When I’m logged on as a new admin user, TinyMCE works for all editing, except within SiteOrigin Editor Widget
    4) Ticking and unticking the box does not change the behavior.

    Hopefully these screen shots will show up shared from my OneDrive account for you. Each will walk you through what’s going on so you can see it visually.

    Example 1
    Example 2
    Example 3
    Example 4
    Example 5

  5. 5 days, 3 hours ago dbachen

    I used the img link in the editor to try and provide those examples, but it doesn’t appear to have worked. My guess is because they are a OneDrive link, and not directly linked to a graphic file, so the editor blocked them thinking they might be malicious.

    You’ll have to follow the raw links provided here, since the editor seems to have blocked them. I tested to make sure these were public.

    1) https://onedrive.live.com/?cid=81DB7F49C816B19C&id=81DB7F49C816B19C%2112066&parId=81DB7F49C816B19C%2112062&o=OneUp
    2) https://onedrive.live.com/?cid=81DB7F49C816B19C&id=81DB7F49C816B19C%2112065&parId=81DB7F49C816B19C%2112062&o=OneUp
    3) https://onedrive.live.com/?cid=81DB7F49C816B19C&id=81DB7F49C816B19C%2112067&parId=81DB7F49C816B19C%2112062&o=OneUp
    4) https://onedrive.live.com/?cid=81DB7F49C816B19C&id=81DB7F49C816B19C%2112064&parId=81DB7F49C816B19C%2112062&o=OneUp
    5) https://onedrive.live.com/?cid=81DB7F49C816B19C&id=81DB7F49C816B19C%2112063&parId=81DB7F49C816B19C%2112062&o=OneUp

  6. 4 days, 5 hours ago Alex S Hi, I Work Here

    Hi Dbachen,

    Thanks. Please navigate to WP AdminSettingsTinyMCE Advanced and add the Toggle Button to the first toolbar. Please open the editor (using the account that is missing the other toolbars) and tick the Toggle Toolbar button. Does that help?

  7. 4 days, 51 minutes ago dbachen

    Hey Alex,

    Great catch! When using the regular visual editor, the toolbar would show up automatically.
    Once I added the toggle button, the visual editor still work with showing it automatically (and shows the toolbar toggled on). In addition, since it was added to the first row of the regular toolbar, it became available inside the SiteOrigin page builder as well. By default it was untoggled, but I could easily show it. Once toggled, it was remembered as a setting on other pages as well.

    Interesting that with the default admin it never had to be “toggled on”. Maybe the plugin install sets it as “on” for that user. But for a new user, it wasn’t storing that desire to show the toolbar in the user preferences.

    At least there is a repeatable solution that’s now documented if anyone else runs into this.

    I appreciate your assistance in tracking it down.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More