Home>Support>The text editor has stopped working for me

The text editor has stopped working for me

Good morning, the PageBuilder editor has stopped working, the constructor is not visible and the page looks very bad to me.
When I deactivate the plugin and reload the backend, the page goes blank.
Any solution?

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 9 months, 13 days ago Andrew Misplon Hi, I Work Here

    Hi Jose

    Thanks for reaching out.

    When able, please, try seeking a working baseline. If you temporarily deactivate all plugins except for Page Builder, does the issue resolve?

  2. 9 months, 13 days ago Jose Bermejo

    Hi, I have tried to disable all plugins and it has not worked.
    When I deactivate the “page builder” plugin the page is blank.
    What could this be due to?

  3. 9 months, 13 days ago Andrew Misplon Hi, I Work Here

    Hi Jose

    Thanks for taking that first step. Please, could you take a screenshot of what you’re seeing when all plugins are enabled? You can upload screenshots to Imgur.com or any cloud-type service like Dropbox and post the link here.

  4. 9 months, 12 days ago Jose Bermejo

    Hello, this is how I see the editor of my website with all the plugins activated.
    http://catformacio.org/wp-content/uploads/img_catformacio.png

  5. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update. Please, try extending your plugin conflict test as follows:

    * Temporarily deactivate all plugins except for Page Builder.
    * Temporarily switch to a default theme like Twenty Nineteen.
    * Re-check the page in the screenshot. Does the issue persist?

  6. 9 months, 12 days ago Jose Bermejo

    I have changed the template, deactivated all the plugins and it still looks the same as in the previous image that I sent.
    When I deactivate the Page Builder by SiteOrigin plugin, the editor page goes blank.

  7. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update.

    With a default theme activated and all plugins deactivated except for Page Builder, please, edit the page in question. Open the browser console. If errors are present in red text, please, take a screenshot and send a link to the screenshot.

    https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

  8. 9 months, 12 days ago Jose Bermejo

    By deactivating everything and setting the theme: Twenty Nineteen the editor works again.
    In the console it does not give me any error.

  9. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Thanks. When does SiteOrigin Page Builder break? When you reactivate your theme?

  10. 9 months, 12 days ago Jose Bermejo

    If so, I am attaching a screenshot so you can see the errors in the console.
    http://catformacio.org/wp-content/uploads/error_catformacio.png

  11. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Sorry I’m not with you. Please, could you confirm.

    Does Page Builder function normally with a default theme activated and all other plugins deactivated?

    If the answer to the above question is yes. When does Page Builder break?

  12. 9 months, 12 days ago Jose Bermejo

    Let’s see, with all the plugins disabled and with the default template the constructor works.
    If I activate my theme I am updating the template builder it stops working.

  13. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Thanks.

    * Which theme are you using?

    * Does the issue occur on all Page Builder pages?

  14. 9 months, 12 days ago Jose Bermejo

    I am using the child of Moesia Pro (child-moesia-pro-ii).
    This happens on every page of the editor.

  15. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Thanks. Does the issue occur if you switch to the parent theme?

  16. 9 months, 12 days ago Jose Bermejo

    Yes, it happens if I change the main topic.

  17. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    By topic, do you mean theme? To confirm, the issue persists if you switch from your child theme to Moesia Pro?

  18. 9 months, 12 days ago Jose Bermejo

    Yes, the error persists.
    In both tracks, both the original and the son

  19. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Thanks for confirming.

    Please, upload a copy of Moesia Pro to Dropbox or any cloud location and email a link to the ZIP file to [email protected]. We’ll take a look from there.

  20. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Hi Jose

    Thanks for the email.

    The folder structure in Google Drive is a bit unusual. I think the parent theme is in /child-moesia-pro-ii/moesia-pro-ii. If I try installing that folder, moesia-pro-ii as a theme I get a fatal error. Are you perhaps able to download just the premium theme ZIP file without anything else?

  21. 9 months, 12 days ago Jose Bermejo

    Let me resend it to you in case an error has occurred.

  22. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Hi

    Normally, I’d expect there to be only two folders. One for the parent theme one for the child theme. The two folders should be at the same file level. In Google Drive I see:

    moesia-pro-ii: This folder isn’t a complete theme.
    child-moesia-pro-ii: The parent is in this folder, I’m not sure why.

  23. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Hi, thanks for the new ZIP file.

    I can use Moesia Pro and Page Builder. Please, find two screenshots here https://imgur.com/a/evz4dgQ.

    When able, please, try:

    * Reinstall the parent theme. With Twenty Nineteen or any default theme activated, delete Moesia Pro and then reinstall using the ZIP file you sent a few moments ago.

    * Reinstall Page Builder. You can download the ZIP file here https://wordpress.org/plugins/siteorigin-panels. Then go to PluginsAdd NewUpload Plugin. Upload the plugin ZIP file, overwriting the existing version when prompted to do so.

    * Once the above is done try a conflict test again. Activate Moesia Pro (the parent theme) and activate Page Builder. Deactivate all other plugins. Does the issue persist in this state?

  24. 9 months, 12 days ago Jose Bermejo

    The error persists, it remains the same as at the beginning.

  25. 9 months, 12 days ago Andrew Misplon Hi, I Work Here

    Hi Jose

    Under our premium support scope where we have the budget, we can log in and directly assist with edge case challenges like this. Please, consider a SiteOrigin Premium license. We’ll be able to log in to your WP installation and server if necessary to directly assist.

    Moesia Pro and Page Builder are functioning together in my local installation. If you’d like us to try and assist as we are now, please, take another screenshot of your browser console with:

    * Moesia Pro activated. The parent, not the child.
    * All plugins deactivated except for Page Builder.

    Open the console, take a screenshot and send a link in the above state. We’ll try to make a suggestion from there.

    Thanks

    Andrew

  26. 9 months, 11 days ago Jose Bermejo

    Hello Andrew, what is the price of the license?
    Thanks!

  27. 9 months, 11 days ago Andrew Misplon Hi, I Work Here

    Hi Jose

    There are a few license options to choose from. Please, click the Buy Now button to view them Download: SiteOrigin Premium. You can apply the NOVEMBER30 code during checkout for 30% off.

  28. 9 months, 4 days ago Jose Bermejo

    Hi, in the editor I get a javascript error.
    Maybe the error that the editor does not appear is due to this?
    Error: panelsOptions is not defined

  29. 9 months, 4 days ago Andrew Misplon Hi, I Work Here

    Hi Jose

    There is most likely another JavaScript error that is causing Page Builder to fail.

  30. 9 months, 4 days ago Andrew Misplon Hi, I Work Here

    You can send us a screenshot of the console by uploading it to imgur.com or any sharing site and sending the link.

  31. 9 months, 4 days ago Jose Bermejo

    Link images: https://imgur.com/a/AYkjQcx

  32. 9 months, 4 days ago Andrew Misplon Hi, I Work Here

    Thanks. Chat over email.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More