Home>Support>SiteOrigin is not working after WordPress 5.5 update

SiteOrigin is not working after WordPress 5.5 update

Hi,

We know this issue is prevalent and happening at the moment, however, we cannot find any solution to our problem from previous threads. Therefore we wish to build our case here. Our website is https://ryzconsulting.com. Currently, there is an issue as well with our HTTPS or SSL (issue to connect WordPress/Jetpack with our host/server), but looking at now. FYI, we are running on PHP 7.2.

To get us started, here is the list of widgets from SiteOrigin that we currently use on our website:
1. SiteOrigin Hero
2. SiteOrigin Headline
3. SiteOrigin Features
4. SiteOrigin Post Carousel
5. SiteOrigin Editor
6. SiteOrigin Button
7. SiteOrigin Layout Slider
8. SiteOrigin Image
9. SiteOrigin Accordion

Additionally, here is the list of other plugins that we are using:
1. Akismet Anti-Spam
2. Enable jQuery Migrate Helper (as recommended in another thread)
3. Google Analytics
4. Health Check & Troubleshooting
5. Jetpack by WordPress.com
6. Loginizer
7. Page Builder by SiteOrigin
8. PHP Compatibility Checker
9. SiteOrigin Installer
10. SiteOrigin Widgets Bundle

The front-end’s layout (as we can see from the internet browser) is awful, but when we look at the layout from the ‘live editor’ it is very normal. All of the wording and paragraphs are still there, and the buttons are working. It is just a matter of layout and size. Perhaps something wrong with the widgets?

Please kindly advises us, thank you.

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 1 year, 5 months ago Andrew Misplon Hi, I Work Here

    Hi Ryzconsu

    Thanks for reaching out.

    You can remove and delete the SiteOrigin Installer plugin if you’d like, unrelated to the issue you’re posting about.

    Are you able to establish a working baseline? Does Page Builder function normally if you switch to Twenty Twenty and deactivate all plugins except Page Builder and the Widgets Bundle?

  2. 1 year, 5 months ago ryzconsu

    Hi Andrew,

    Thanks for replying. To be honest none of us is an expert here, so we have been keeping things just like before the WP 5.5 update. We understand to switch off-on the plugins to root the problem, but is that okay? And what would happen to our website if we switch the theme to Twenty Twenty and deactivate all plugins? We will lose them (100%) or once we revert back to SiteOrigin Corp, it would be restored as normal?

    Otherwise, we will backup the website first. And we will delete the SiteOrigin Installer.

    Thanks again.

  3. 1 year, 5 months ago Andrew Misplon Hi, I Work Here

    The goal of switching to Twenty Twenty theme and deactivating all other plugins is to find a working baseline. We don’t yet know if a plugin or theme conflict is the issue, this test is to see if we can find a point from which we can run tests. If you’re using Corp, you don’t need to switch to Twenty Twenty, you can just temporarily deactivate all non-SiteOrigin plugins and see if the issue resolves in that state. No data will be lost during this process. Making a backup/restore point is good practice in general. Thanks.

  4. 1 year, 5 months ago ryzconsu

    Hi Andrew,

    We have deactivated all plugins both on the network and on the site, except:
    1. Page Builder by SiteOrigin
    2. SiteOrigin Widgets Bundle

    But the problem persists. Any idea what is next? By the way, we got this message from ‘Site Health’:
    One or more required modules are missing. PHP modules perform most of the tasks on the server that make your site run. Any changes to these must be made by your server administrator.
    The WordPress Hosting Team maintains a list of those modules, both recommended and required, in the team handbook (opens in a new tab).
    Warning The optional module, fileinfo, is not installed, or has been disabled.
    Warning The optional module, imagick, is not installed, or has been disabled.
    Error The required module, mbstring, is not installed, or has been disabled.

    Does it have any impact on our issue? Is this something that we need to solve with our hosting provider?

  5. 1 year, 5 months ago Andrew Misplon Hi, I Work Here

    Thanks. With all non-SiteOrigin plugins deactivated, please, recreate the Page Builder issue by editing a page. While editing a page, open the browser console, take a screenshot, upload to imgur.com, or similar and send us the link. Here is how to check the console https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

  6. 1 year, 5 months ago ryzconsu

    Hi Andrew,

    Please find the attached screenshots per your instruction. We did check the console from both ‘live editor’ on Google Chrome and guest view on Microsoft Edge. Looks like there is nothing at all. The one that you will see on the left side of the ‘live editor’ is how the website should look like. The one from Microsoft Edge is the bug version.

    https://imgur.com/d6eVb2n
    https://imgur.com/wAleZpT <– correct, see left side, live editor view
    https://imgur.com/Vrg2ezT <– correct, see left side, live editor view
    https://imgur.com/EH3SXVK <– correct, see left side, live editor view
    https://imgur.com/OuVgnNd <– wrong, guest view, live editor view

  7. 1 year, 5 months ago Andrew Misplon Hi, I Work Here

    Thanks. To confirm, the issue is that your site isn’t presenting normally in MS Edge? Is that correct? The site seems normal to me viewing it in Chrome and Firefox and Safari.

  8. 1 year, 5 months ago ryzconsu

    Hi Andrew,

    No, it wasn’t normal at all. We opened the website on Google Chrome, MS Edge, and Safari on iPhone too. Could you share what you see there?

  9. 1 year, 5 months ago Andrew Misplon Hi, I Work Here

    Sure. Here is how your site looks on my computer in Chrome https://imgur.com/a/PjzZooR.

  10. 1 year, 5 months ago ryzconsu

    Hi Andrew,

    All good! We cleared our browser’s cache and everything is back to normal. Thanks a lot for your help!

  11. 1 year, 5 months ago Andrew Misplon Hi, I Work Here

    Super, glad to hear all is well. Cheers for now :)

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More