Home>Support>Remove “Leave a Comment” from pages

Remove “Leave a Comment” from pages

Hello.
I am using the Influencer theme to build a site. Please help me remove “Leave a comment” from below all the pages. Tried un-checking all options in the ‘discussion settings’, doesn’t work.

URL: http://getstarted.me

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 8 years, 27 days ago Andrew Misplon Hi, I Work Here

    Hi Kajal

    Please find our tutorial for this here: https://siteorigin.com/basics/disable-wordpress-comments/.

    Hope that helps.

  2. 8 years, 27 days ago Kajal Patel

    Hey Andrew,

    The 2 options shown in the video are not available for me.. Please help.

  3. 8 years, 27 days ago Andrew Misplon Hi, I Work Here

    Have you clicked Screen Options top right and checked the Discussion checkbox?

  4. 8 years, 27 days ago Kajal Patel

    There is no discussion check box under Sreen Options. How can I provide you a screenshot?

  5. 8 years, 27 days ago Andrew Misplon Hi, I Work Here

    Check for a checkbox called “Comments” in Screen Options. Once that’s checked Comment options will be available below the editor.

  6. 8 years, 27 days ago Kajal Patel

    I don’t know how, but the options now appear. Its done. Thanks very much for your help. :)

  7. 8 years, 26 days ago Andrew Misplon Hi, I Work Here

    Super, glad to hear you made progress here.

    WP 4.0 did change the naming there. We’ll be sure to update our tutorial page as soon as we have a moment.

    All the best.

  8. 7 years, 8 months ago Yaron Glazer

    For some reason the comment box is not removed from the page, and all the checkbox are unchecked on both options.

    Do you have any idea?

  9. 7 years, 8 months ago Andrew Misplon Hi, I Work Here

    Hi Yaron

    The global settings only apply for new pages/posts. On each page/post you’ll need to click Screen Options top right and check the Discussion checkbox, then scroll down to below the Visual Editor and un-check the comment settings there. Also try going to the Posts overview page and click Quick Edit next to a post title, un-check the comment setting there if it’s activated.

    For a follow-up on this, please open a fresh support thread, we’ll help out as soon as possible:
    Page: New Thread

  10. 7 years, 8 months ago Yaron Glazer

    Great It worked, I check the Discussion checkbox and un-check the comment settings there.
    Thanks

  11. 7 years, 8 months ago Andrew Misplon Hi, I Work Here

    Super, glad that helped. All the best :)

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More