Home>Support>PHP warnings for Site Origin Widgets Bundle

PHP warnings for Site Origin Widgets Bundle

Hi there,

Running latest version of the plugin alongside PHP 8, seeing the following warnings:

WARNING: wp-content/plugins/so-widgets-bundle/base/inc/widgets/base-slider.class.php:400 – Undefined variable $instance

WARNING: wp-content/plugins/so-widgets-bundle/base/inc/widgets/base-slider.class.php:400 – Trying to access array offset on value of type null

WARNING: wp-content/plugins/so-widgets-bundle/widgets/hero/hero.php:417 – Undefined variable $button_code

WARNING: wp-content/plugins/so-widgets-bundle/base/inc/widgets/tpl/carousel.php:34 – Undefined array key “item_overflow”

Thanks in advance! :)

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 1 year, 7 months ago Andrew Misplon
    Hi, I Work Here

    Hi Daniel

    Thanks for letting us know. I’ll log the above; we’ll attend in the next update.

    Cheers :)

    Andrew

  2. 1 year, 7 months ago Daniel Kim

    Thank you so much. In the mean time, happy to test out any early release you all want to try.

  3. 1 year, 7 months ago Andrew Misplon
    Hi, I Work Here

    Much appreciated! Alex will update the issue at https://github.com/siteorigin/so-widgets-bundle/issues/1671 when he attends.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More