Home>Support>PHP Errors – SiteOrigin Widget Bundle

PHP Errors – SiteOrigin Widget Bundle

Good day I have Query Monitor installed and recently updated to PHP 8.0 – I have the following warnings pop up but not 100% sure what they mean. I am not a developer. The website seems to be working fine but just wondering if this is something that will be fixed in the next update or if there is something I can fix myself.

Undefined variable $instance (count1)
wp-content/plugins/so-widgets-bundle/base/inc/widgets/base-slider.class.php:400 – Plugin: so-widgets-bundle

Trying to access array offset on value of type null (count3)
wp-content/plugins/so-widgets-bundle/base/inc/widgets/base-slider.class.php:400 – Plugin: so-widgets-bundle

Undefined variable $icon_color
wp-content/themes/vantage/inc/widgets.php:75 – Plugin: siteorigin-panels

I am also not sure if this provides you with enough detail to look into the problem.

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 3 months, 28 days ago Alex S Hi, I Work Here

    Hi Deoncol,

    Thank you for the report. These will be fixed in the next SiteOrigin Widgets Bundle and Page Builder by SiteOrigin updates. For reference, here is the fix for the first two notices and here’s the fix for last one
    The last notice.

    Kind regards,
    Alex

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More