Home>Support>Page Builder resulting in white screen

Page Builder resulting in white screen

When I attempt to edit a page OR post in WordPress, I’m presented with a white screen. I’ve enabled debug mode and get the message:

Deprecated: Hook block_categories is deprecated since version 5.8.0! Use block_categories_all instead. in /home2/coolbac1/public_html/wp-includes/functions.php on line 5754

This is a general plugin conflict message, so after turning off and reactivating all plugins one by one, Page Builder by Site Origin was found to be the culprit.

I’ve already tried increasing the memory limit and deleting and reinstalling the plugin.

I have several pages that were created with Page Builder and can’t get by without it at this point.

Solutions welcome!

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 4 days, 8 hours ago Andrew Misplon Hi, I Work Here

    Hi, thanks for reaching out.

    Please, try to establish a working baseline. Temporarily deactivate all plugins except for Page Builder. With only Page Builder activated, does the issue persist?

  2. 4 days, 21 minutes ago CoolB

    Hi Andrew,
    I was able to resolve the problem by rolling back my PHP version from 8.0 to 7.4. Things work now but that probably still means there’s some updates to be made in Page Builder for the latest PHP version.

  3. 4 days, 15 minutes ago Andrew Misplon Hi, I Work Here

    Thanks for the update; I’m glad to hear you’re making progress.

    We don’t have any open PHP 8 issues that we’re aware of. We’re working with PHP 8+ locally in our testing environments and here in SiteOrigin.com. If you’d like to dig a bit deeper, please, set WP_DEBUG to true in your WordPress wp-config.php file in your WordPress root and recreate the issue. Below WP_DEBUG add:

    define( 'WP_DEBUG_LOG', true );

    A debug.log file will be written to your /wp-content/ folder. Please let us know if there are any errors related to SiteOrigin plugins.

    Thanks again.

    Andrew

  4. 4 days, 14 minutes ago Andrew Misplon Hi, I Work Here

    A quick reminder to set DEBUG and DEBUG_LOG to false when done troubleshooting.

    https://wordpress.org/support/article/debugging-in-wordpress/

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More