Home>Support>Page Builder postloop widget shows pagination but loads same page when clicked

Page Builder postloop widget shows pagination but loads same page when clicked

We are using the Page Builder post loop widget to show the ‘rest of the posts’ (indexed @ 9) after a headline grid loop showing the latest 9 in another section.

The post loop (using Vantage’s blog loop template) displays as expected and shows the proper pagenation at the end.. HOWEVER when you navigate to any of the page links, it just basically reloads the same main page with all the same posts in the ‘rest of the posts’ section.

You can take a look here: https://www.a4at.com/ and see what I mean.

How can we fix this?

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 2 months, 12 days ago PPN Steve

    Quick UPDATE: It seems to be directly related to using the offset (offset=9) in the additional query arguments field. When I remove the entry, the pagenation links loads the next/proper page of posts.. however it’s duplicating the headline grid’s posts as well.

  2. 2 months, 11 days ago Alex S Hi, I Work Here

    Hi Steve,

    This happens as a result of how WordPress handles queries at the pagination level. It’s possible to avoid this with some custom coding, but it will require modifications to how the templates work. This isn’t something we do by default as it does alter the URL of the pagination from a nicer looking “page/2” to something closer to “page-UNIQUE-ID/2”

    We’ve outlined how to do Post Loop Widget here. We’re able to assist you with making this customization within our premium support scope.

    Kind regards,
    Alex

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More