Home>Support>Page Builder and Learndash 3

Page Builder and Learndash 3

Hi there,

When I want to use Page Builder to build modules and lessons in Learndash, a part of the site origin editor keeps disappearing behind the black admin wordpress menu on the left side. I have the wordpress 5.2.1 version installed as well as the page builder 2.10.5 and LEarndash 3.0.3.1. ANyone else experiencing the same problem? Doesn’t matter if I turn the classic editor on or off. Even tried using different browsers besides chrome (such as edge).

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 3 months, 10 days ago Tommop

    I’ve got it figured out I guess. You can collapse the wordpress admin menu on the left and then everything is visible!

  2. 3 months, 9 days ago Tommop

    Unfortunately … some parts at the top of the page are still are not displayed but hidden underneath part of the learndash menu.

  3. 3 months, 9 days ago Andrew Misplon Hi, I Work Here

    Hi, thanks for reaching out.

    Is Learndash a premium plugin, looks like it. I could take a look, please upload the plugin ZIP file to Dropbox or Drive or similar and email me the link at [email protected]. Cheers.

  4. 3 months, 9 days ago Tommop

    Hi Andrew,

    Thanks for your reply. I’ve uploaded the plugin and a screencast to a Google Drive folder that I’ve shared with the email you ‘ve mentioned in your reply. Looking forward to hearing from you.

    Tommy

  5. 3 months, 5 days ago Andrew Misplon Hi, I Work Here

    Hi Tommy

    Apologies for the delay. Alex was able to investigate for us and found the following:

    Unfortunately, I’ve identified the cause of this issue. This issue is caused by LearnDash LMS plugin adding the following CSS:

    #adminmenuwrap, #wpadminbar {
        z-index: 159001;
    }

    This CSS increases the WordPress admin menu layer to a significantly higher amount. This is problematic as we’ve designed our modal with the base layer in mind which is resulting in our layer being hidden. Can you perhaps reach out to Learndash and report this issue?

    To hotfix this problem, please, try adding the following to CustomizeAdditional CSS:

    .block-editor .so-content, .block-editor .so-left-sidebar, .block-editor .so-overlay, .block-editor .so-right-sidebar, .block-editor .so-title-bar, .block-editor .so-toolbar, .so-panels-dialog .so-content, .so-panels-dialog .so-left-sidebar, .so-panels-dialog .so-overlay, .so-panels-dialog .so-right-sidebar, .so-panels-dialog .so-title-bar, .so-panels-dialog .so-toolbar {
    	z-index: 159002;
    }
  6. 3 months, 5 days ago Tommop

    Hi Andrew,

    Thanks for looking into this problem. The additional CSS code seems to do the trick but only when I activate the classic editor! I’ve forwarded your feedback to the learndash team. Let’s hope they are able to fix it.

    Kindly,

    Tommy

  7. 3 months, 4 days ago Andrew Misplon Hi, I Work Here

    Sorry about that, please remove the CSS from Additional CSS.
    Go to PluginsAdd New and search for a plugin called Code Snippets, install and activate.
    Go to SnippetsAdd New and create a new snippet. Name it as you’d like and insert the following in the snippet body:

    function tommop_custom_admin_css() {
      echo '<style>
    	.block-editor .so-content, .block-editor .so-left-sidebar, .block-editor .so-overlay, .block-editor .so-right-sidebar, .block-editor .so-title-bar, .block-editor .so-toolbar, .so-panels-dialog .so-content, .so-panels-dialog .so-left-sidebar, .so-panels-dialog .so-overlay, .so-panels-dialog .so-right-sidebar, .so-panels-dialog .so-title-bar, .so-panels-dialog .so-toolbar {
    		z-index: 159002;
    	}
      </style>';
    }
    add_action( 'admin_head', 'tommop_custom_admin_css' );

    Set the snippet to only run in the site administration area, save and activate.

    Ref: https://css-tricks.com/snippets/wordpress/apply-custom-css-to-admin-area/

  8. 3 months, 3 days ago Tommop

    Hi Andrew,

    There still is a problem. If you now want to add a link to an image or text. The pop-up screen in which you can add the link is hidden by the siteOrigin Editor window.

    Tommy

  9. 3 months, 3 days ago Andrew Misplon Hi, I Work Here

    Please, try swapping out the function with the below:

    function tommop_custom_admin_css() {
    	echo '<style>
    		.block-editor .so-content, .block-editor .so-left-sidebar, .block-editor .so-overlay, .block-editor .so-right-sidebar, .block-editor .so-title-bar, .block-editor .so-toolbar, .so-panels-dialog .so-content, .so-panels-dialog .so-left-sidebar, .so-panels-dialog .so-overlay, .so-panels-dialog .so-right-sidebar, .so-panels-dialog .so-title-bar, .so-panels-dialog .so-toolbar {
    			z-index: 159002;
    		}
    		div.mce-inline-toolbar-grp {
    			z-index: 159003;
    		}
    	</style>';
    }
    add_action( 'admin_head', 'tommop_custom_admin_css' );
    

    Please, consider contacting LearnDash to help out with the situation, it would be most appreciated.

  10. 3 months, 3 days ago Tommop

    Hi Andrew,

    You’ve made my day. It works!

    Tommy

  11. 3 months, 3 days ago Andrew Misplon Hi, I Work Here

    Glad that helped :) All the best.

  12. 3 months, 2 days ago Tommop

    Hi Andrew,

    I’ve just updated the plugin and now we’re back to the previous problem: If you now want to add a link to an image or text. The pop-up screen in which you can add the link is hidden by the siteOrigin Editor window.

  13. 3 months, 2 days ago Andrew Misplon Hi, I Work Here

    Hi :)

    Does the issue persist if you deactivate the snippet within Code Snippets?

    Did you report the issue to LearnDash before the update?

    Thanks

  14. 3 months, 2 days ago Tommop

    Sometimes it’s easy … I deactivated the snippet and now it seems to work great (again)! Thanks.

    I did report it to Learndash

  15. 3 months, 2 days ago Tommop

    I was too fast … It only worked on a page but not when I create new learndash pages. If I active the snippet again I get the siteorigin window but when I add a row and insert the SiteOrigin Editor and I want to add a link, I can add the link but the screen with the settings is hidden behind the siteorigin window … #frustrating

  16. 3 months, 2 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update. Please, let LearnDash know about the issue. We’re a small team working with limited resources, especially here on the forums where we’re supporting our free products. Within our SiteOrigin Premium support scope, we’re better able to assist with third-party conflicts of this nature.

  17. 3 months, 2 days ago Tommop

    Hi Andrew,

    I understand (and the support on the free forum is still great!). I will let them know. But just to be clear. I updated the siteOrigin plugin (not the LD plugin). Before it worked great with the extra snippet you provided and now suddenly it doesn’t anymore.

  18. 3 months, 2 days ago Andrew Misplon Hi, I Work Here

    Thanks for the clarification.

    Alex has a copy of LearnDash, I’ll ask him to take another look tomorrow. Ideally, the core issue needs to be resolved. That issue is, unfortunately, beyond our control.

  19. 3 months, 2 days ago Tommop

    If you want to, I can give you admin rights (or FTP access) to a test site which has LD and Siteorigin installed. But then I need an email to send you the login/password. You have my email as a registered user on this site I guess.

  20. 3 months, 2 days ago Andrew Misplon Hi, I Work Here

    Ideally, our free support scope is meant to basic settings assistance and basic troubleshooting. We’d love to help with everything but it isn’t viable. I’ve messaged Alex and asked him to take another look. I’ll let you know as soon as I hear back. Thanks.

  21. 3 months, 2 days ago Andrew Misplon Hi, I Work Here

    Please, try replacing the previous function with the following:

    function tommop_custom_admin_css() {
    echo '<style>
    	.block-editor .so-content, .block-editor .so-left-sidebar, .block-editor .so-overlay, .block-editor .so-right-sidebar, .block-editor .so-title-bar, .block-editor .so-toolbar, .so-panels-dialog .so-content, .so-panels-dialog .so-left-sidebar, .so-panels-dialog .so-overlay, .so-panels-dialog .so-right-sidebar, .so-panels-dialog .so-title-bar, .so-panels-dialog .so-toolbar {
    		z-index: 159002;
    	}
    	div.mce-inline-toolbar-grp {
    		z-index: 159003;
    	}
    
    	#wp-link-backdrop {
    		z-index: 159004;
    	}
    
    	#wp-link-wrap {
    		z-index: 159005;
    	}
    </style>';
    }
    add_action( 'admin_head', 'tommop_custom_admin_css' );
  22. 3 months, 2 days ago Tommop

    Hi Andrew,

    Great job! It works fine again!

  23. 3 months, 1 day ago Andrew Misplon Hi, I Work Here

    Super, glad that helps :)

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More