Home>Support>No warning prompt for unsaved changes

No warning prompt for unsaved changes

Hello,

We love the flexibility that the page builder offers our users. However, we have noticed that when editing a page within the admin, if the user tries to navigate away from the page without clicking update/publish, we do not get a prompt that pops up asking the user to confirm their navigation or alert them of unsaved changes. Is there a way to have this show?

Thanks in advance for your help,
Jessica

This is a free community support forum. Replies are not guaranteed. If you need professional email support, please purchase a SiteOrigin Premium license.

  1. 4 months, 6 days ago Alex S Hi, I Work Here

    Hi Jessica,

    That’s odd. That prompt should be visible. So, to confirm, this happens for all changes, correct?

    Please navigate to WP AdminSettingsPage Builder and open the Content tab. Please ensure Copy Content is ticked.

  2. 4 months, 6 days ago jessica@softshelldesign.com

    Hi Alex,

    Thanks so much for your response and help.

    Yes, “Copy Content” is ticked.

    We have double checked and all pages that use the PageBuilder do not show the prompt.

    When we make an edit within the SiteOrigin Editor widget and then click on “All Pages” within the sidebar of WP, it goes to the page list without giving us the “Are you sure you want to leave” prompt.

    Thanks again,
    Jessica

  3. 4 months, 5 days ago Alex S Hi, I Work Here

    Hi Jessica,

    That’s odd. Would it be possible for you to create a temporary admin account for us so we can log in and take a look?

  4. 4 months, 5 days ago Private Message - Alex S Hi, I Work Here

    This is a private message.

  5. 4 months, 4 days ago jessica@softshelldesign.com

    Hello Alex,

    Thank you, yes, we will get this set up. There may be a slight delay since we need to get approval from the client.

    Thanks again,
    Jessica

  6. 3 months, 19 days ago jessica@softshelldesign.com

    Hello Alex,

    Sorry for the delay.

    I have set you up with a user, you should have received the information via email.

    Please let me know.

    Thanks so much,
    Jessica

  7. 3 months, 19 days ago Private Message - WordPress

    This is a private message.

  8. 3 months, 18 days ago Alex S Hi, I Work Here

    Hi Jessica,

    Thanks. I sadly wasn’t able to replicate this. Are you able to replicate this issue on this page?

  9. 3 months, 18 days ago jessica@softshelldesign.com

    Hello Alex,

    We went into the Community page, changed a ; to a :, clicked done, then navigated away from the page by clicking on Services. It did not give us a prompt.

    On your test page we didn’t see a SiteOrigin Editor Widget in there. We saw a Hero, Headline, Features, Post Carousel, etc… We went ahead and added a SiteOrigin Editor into the test page, then navigated away and it did not ask us if we wanted to leave this site.

    Perhaps the SiteOrigin editor widget is the issue?

    Please let me know.

    Thanks!
    Jessica

  10. 3 months, 16 days ago Alex S Hi, I Work Here

    Hi Jessica,

    Unfortunately, I’m unable to replicate this issue on your community page either. Are you able to replicate this issue in a different browser or on a different computer?

    To answer your thought, the above image is taken after editing the SiteOrigin Editor widget on that page.

  11. 3 months, 13 days ago jessica@softshelldesign.com

    Hi Alex,

    It’s the browser! I’m so sorry, I should have done a cross browser check first thing. I really apologize and thank you so much for your prompt and polite support.

    Thanks again,
    Jessica

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More