Home>Support>Mobile menu not working with Corp theme on iPhone 7

Mobile menu not working with Corp theme on iPhone 7

When I tap on the mobile menu icon on my iPhone nothing happens.

I have searched the forum and tried all the actions advised; toggling the mobile menu off and on in the customise interface, adjusting the collapse size, deactivating and re-activating my plugins, emptying cache between tests, etc – nothing works.

It was working perfectly the last time I checked.

Can anyone help me…?

Thank you!

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 3 years, 11 months ago Andrew Misplon Hi, I Work Here

    Hi David

    Please send a link and we’ll take a look.

    (A quick note on plugin conflict tests for the future. There is a general misunderstanding in this area. The important part is seeing if the issue resolves with all plugins deactivated. Activating and deactivating plugins won’t usually fix a problem. The important part of the test is can you establish a working baseline with all plugins deactivated? If you can, then you’d reactivate plugins one by one to find which plugin causes the issue.)

  2. 3 years, 11 months ago David Key

    Hi Andrew,

    Thanks very much for responding – and so quickly :-)

    The site is live at: http://www.ecoself.net

    I did follow the plugin procedure you outline – deactivated them all, checked after cleared caches to see if the issue resolved, and then re-activated them one-by-one, clearing caches and checking after each re-activation.

    Just to add… I checked on an old iPhone 5s just now and the menu worked OK on that. It’s just on my iPhone 7 with the latest version of IOS. I don’t have access to any other devices to check…

    Thanks again.

  3. 3 years, 11 months ago Andrew Misplon Hi, I Work Here

    Thanks for the link and feedback.

    Which browser are you testing with? On my side, it’s working normally (iOS Chrome).

    (If the issue doesn’t resolve with all plugins deactivated then the test has failed, you haven’t been able to establish a working baseline and you can just turn on all plugins at once.)

  4. 3 years, 11 months ago David Key

    I’m using Safari with iOS 11.4.

  5. 3 years, 11 months ago David Key

    OK… it’s a Safari thing. It works with Firefox on my iPhone. I wonder how I get it to work with Safari…?

  6. 3 years, 11 months ago Andrew Misplon Hi, I Work Here

    Thanks. Seems to be ok for me in iOS Safari. It is possible to clear the cache in Safari if you Google the steps you should find a few help posts on that. It might be worth a try.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More