Home>Support>maps.googleapi in every header – maps widget disabled

maps.googleapi in every header – maps widget disabled

Hi outthere,

I use SiteOrigin for years. Unfortunately I was obliged to make my site GDPR EU conform.
I disabled all the google fonts but still there are in every site header strings like

Although the site-origin maps widget is not enabled, I see within the chrome developing mode this string.
This does not fulfill the German GDPR conformity rules. In former times I assume – years ago – I had used the maps widget with a valid API key. However, I do not use it. The page whereon it was used is not any longer available.

How can I get rid off this link?

Please help since time urges.
In case you need credentials, let me know und you will get access to my staging site stagin.knutmenzel.de. The issue is still there on knutmenzel.de.

Note: This issue is NOT there on denkerprise.de or staging.denkerprise.de.


This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 14 days, 15 hours ago LiveKnut


    Issue can be solved using the plugin perfmatters from perfmatters.io. Just one click to switch of google maps and all therefore related api calls.

    From my perspective it is NOT an issue with the SiteOrigin (switched all plugins off)Tools, NOR with the theme (copied the theme source code from another site to my site). It is a feature of WP directly.


  2. 14 days, 11 hours ago Andrew Misplon Hi, I Work Here

    Hi Knut

    Thanks for posting your question and for your support; it’s most appreciated.

    You can perhaps also try going to PluginsSiteOrigin WidgetsGoogle MapsSettings and enabling the Require consent before enabling the Google Maps API checkbox.

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More