Home>Support>Main navigation issue when using custom (absolute) links in menu

Main navigation issue when using custom (absolute) links in menu

Hi all,

I’ve set up a (semi) one page site using Corp theme & on the main page I’m using absolute links in the main navigation (eg. https://domain.com/#testimonials) because one section includes links to several posts.

The problem I have is that ALL the navigation links are underlined, when only the active section should be… so the Link Hover Accent Color is displayed on all links, not just the active section, when it should only show for the active section.

How can I make this work correctly? I have to use absolute links in the menu as otherwise the menu on the individual post pages will not work.

Thanks in advance for your help!!

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 3 years, 11 months ago Andrew Misplon Hi, I Work Here

    Hi Vee

    We have a Corp update going out later today. I’ll try work this into the release. It takes some doing. The theme isn’t wrong, all the links get assigned a “current” class in a case like this, the class is assigned by WordPress. What I’ve done in the past is unset that behaviour and then reassigned the class using JavaScript. We can hopefully get this working with current section highlighting, assuming you’ve used SiteOrigin Page Builder row ID’s for the sections. If not we can look at getting that bit working later in the week.

  2. 3 years, 11 months ago Vee_Haitch

    Thanks for the quick reply Andrew. That would be great if you could do that. I’ve been messing around with css trying to get it close to working, but no joy!

    Yes – I set it up using row ids & I know it works if I’m not using absolute URLs as it’s fine on the single post pages. It’s been driving me crazy this afternoon! ?

  3. 3 years, 11 months ago Andrew Misplon Hi, I Work Here

    Thanks :) Let me see what I can get into this release. Hopefully will get it all done shortly.

    • 3 years, 11 months ago Vee_Haitch

      Much appreciated :)

  4. 3 years, 11 months ago Andrew Misplon Hi, I Work Here

    What we have is ready to go. I’m going to push it in the morning GMT+2 so I’m online for the day once it’s released. It’s a big update so it’s better if the team and me are available once the update goes out. Have done loads of testing but still prefer not to push updates right before going offline for the evening. Please, feel free to let me know if anything comes up tomorrow. Thanks :)

  5. 3 years, 11 months ago Vee_Haitch

    Ok – great. Not seen an update as yet & am away after today, so will update once I’m back if I don’t see it before :)

  6. 3 years, 11 months ago Vee_Haitch

    Have updated & it works perfectly. Many thanks for the quick response & the quick roll out :)

  7. 3 years, 11 months ago Andrew Misplon Hi, I Work Here

    Super, glad to hear that did the trick.

    (There will be a smaller update going out this evening but it’s just for some of the WooCommerce elements I missed by mistake.)

    All the best with your site :)

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More