Home>Support>How to remove “index.php” from permalink

How to remove “index.php” from permalink

By AG, 8 years ago. Last reply by Andrew Misplon, 8 years ago.

Hi SiteOrigin Support,

I have tried multiple forums and tried multiple settings, but I can’t figure this out?

Some say it isn’t possible to remove when your website is hosted on a Windows server, other say there is special code you can add to your web.config to force permalink to rewrite and not display “index.php” in the URL.

Among others – here are just a few sources of info that I’ve used to educate myself:
– http://www.sitepoint.com/htaccess-for-all/
– http://www.iis.net/learn/extensions/url-rewrite-module/enabling-pretty-permalinks-in-wordpress
– http://biostall.com/putting-a-wordpress-website-live-on-a-windows-iis-server

Are you guys able to help?

My Goal :

I want to change the site page urls that currently look like this:
– http://www.tradeslot.com/index.php/case-studies/

to look like this:

– http://www.tradeslot.com/case-studies/

URL: http://www.tradeslot.com/index.php/case-studies/

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 8 years, 3 months ago Andrew Misplon Hi, I Work Here

    Hi

    To just cover the very basics here when you go to Settings > General Settings are your WordPress Address (URL) and Site Address (URL) listed as http://www.tradeslot.com ?

  2. 8 years, 3 months ago AG

    Yes.

  3. 8 years, 3 months ago Mick

    First you need to add this extension IIS on the server
    http://www.iis.net/downloads/microsoft/url-rewrite

    Then add this script into your web.config file

  4. 8 years, 3 months ago Mick
    <rewrite>
        <rules>
            <rule name="Main Rule" stopProcessing="true">
                <match url=".*" />
                <conditions logicalGrouping="MatchAll">
                    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                </conditions>
                <action type="Rewrite" url="index.php" />
            </rule>
        </rules>
    </rewrite>
    
    
  5. 8 years, 3 months ago Andrew Misplon Hi, I Work Here

    Thanks for sharing Mick. Has this resolved the challenge on your side?

  6. 8 years, 3 months ago Mick

    I host a lot of Windows servers…. that is the solution

    See it working here https://www.vivenet.com/

  7. 8 years, 3 months ago Andrew Misplon Hi, I Work Here

    Epic, really appreciate the share! Thanks again Mick.

    @Website hosted on Windows Server hope this resolves things on your side.

  8. 8 years, 3 months ago AG

    Thanks Mick – it seems it’s a bit tricky installing URLrewrite? I downloaded the file without a problem, clicked run, waited a few minutes for Windows Installer to process, and then it came up with message saying something like “there are no items to be installed”.

    I forgot to mention that I’m running IIS6… I know this is old, could it be causing a problem?

    Also, thanks for sharing your website link – I noticed that the sticky menu also does not work on my phone just like my site, however it works on desktop. But SiteOrigins demo site (which I’m assuming is on Linux) does work on my phone – http://demo.siteorigin.com/vantage/

    Look forward to your comments.

  9. 8 years, 3 months ago Mick

    I’m running 2008 IIS7

    I no longer have anything running IIS6 so I can’t help you there.

    This is very easy to implement, if its not working for you then its probably time to consider upgrading…..

    Regards,

  10. 8 years, 3 months ago AG

    Appreciate the advise Mick – will do.

    Any thoughts on the sticky menu problem?

  11. 8 years, 3 months ago Andrew Misplon Hi, I Work Here

    The sticky menu is unfortunately purposely disabled on mobile devices for usability reasons. We do currently have a feature request logged to introduce a setting to re-activate it on mobile – we unfortunately haven’t yet launched that setting. Sorry I don’t have more on this point.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More