Home>Support>Help with Responsive Layout on Mobile

Help with Responsive Layout on Mobile

Dear SiteOrgin team,

I’m probably about to ask an incredibly rookie question, so please forgive me if so. I promise I’ve looked over the forums and tried to find the answer for myself.

I’ve been using the Vantage theme for years on another website, to great effect and I appreciate all the love and care your team puts into it. When our company wanted to refresh the main website, I transitioned it to use Vantage as well.

While it looks great on monitors and tablets, something strange is happening on mobile. Let’s say I have a row with three columns, typically, I would expect that row to collapse into three rows with the contents of the left-most cell on top, followed by contents of the second cell, and lastly the right-most cells contents. I have the row layout settings for collapse set to “standard” and “default”.

Instead, it looks like everything is simply being resized to screen width, so that the top content of cells 1,2, and 3 are shrunk and placed beside each other on the same level, and the rest of the content following suit throughout. This makes the text crash together and become illegible.

Under the Customize > Theme Settings > Layout options, I do have Responsive Layout checked and the settings are the same as the other separate website where this works as expected, the only differing component being this website has “Full Width” layout and the other is “Boxed”.

I have seen other similar problems on this forum and tried to follow the responses (such as changing the mobile menu) but that didn’t work for me. I have also tried putting each cell’s contents in its own Layout Builder Widget to see if it would work, but it still shrinks rather than collapsing.

The problem is pretty egregious on the team page (https://kepleybiosystems.com/team/) but happens on the footer as well. And the older site where it works as I expect it to is https://kepleyk9.com/

I appreciate any help, and thanks once again for such a great product.

Best regards,
Lee

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 5 months, 4 days ago Andrew Misplon Hi, I Work Here

    Hi Lee

    Thanks for reaching out and for your support, it’s most appreciated.

    When editing each row, please, can you confirm that the LayoutCollapse Behaviour setting is set to Standard and not No Collapse.

    At SettingsPage BuilderLayout, please, also ensure that Responsive Layout is enabled.

    Do either of the above help?

  2. 5 months, 3 days ago dadgumLee

    Dear Andrew,

    First of all, thank you so much for your response. I truly appreciate it.

    Secondly, geez..it was the second suggestion you made at Settings > Page Builder > Layout and check Responsive Layout. I had been using the one at Customize > Theme Settings > Layout > Responsive Layout and could not figure out why it wouldn’t change anything. I spent so much time on this and feel so dumb. I had no idea that second checkbox was there.

    Either way, that resolves my issue, despite my now wanting to put my head through my desk. I sincerely appreciate your helping me out because it was driving me crazy. Thanks again!

    Best regards,
    Lee

  3. 5 months, 3 days ago Andrew Misplon Hi, I Work Here

    Hi Lee

    Super, glad to hear you’re making progress. Both settings are applicable, one for the theme and the other for Page Builder. If any SiteOrigin queries or requests arise in the future, please, let us know via a new support thread.

    Cheers for now.

    Andrew

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More