Home>Support>Google fonts do not appear

Google fonts do not appear

In the theme customizer, I choose Google web fonts, and they show up in the preview, but when I look at the live site, they are never there. The live site is sicknwrongfilm.com (SFW, I promise). The headings should be in Rammetto One, and they look that way in the preview, but not out on the site.

I’m using SiteOrigin Corp 1.18.9 with WP 5.9.

In the past, I’ve added the code below to the Theme Header in the Theme File Editor, and that makes the font show up, but of course, it gets wiped out every time the theme updates:

<link href="https://fonts.googleapis.com/css2?family=Rammetto+One&display=swap" rel="stylesheet">

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 4 months, 20 days ago Andrew Misplon Hi, I Work Here

    Hi Stephen

    Thanks for reaching out.

    If you inspect the page source you can view the Customizer CSS output by searching for siteorigin-corp-settings-custom. The Google Fonts import is missing. When able, please, try seeking a working baseline. Does the issue resolve if you temporarily deactivate all plugins except for those plugins authored by SiteOrigin?

  2. 4 months, 20 days ago theotherstephen

    Thanks for your help, Andrew. I tried deactivating all of my non-SO plugins and clearing the cache, but that didn’t bring the fonts back.

  3. 4 months, 20 days ago Andrew Misplon Hi, I Work Here

    Thanks. Any change if you deactivate all non-SO plugins and in that state, make a small change to the Customizer settings and save?

  4. 4 months, 20 days ago theotherstephen

    I made a small change in the Customizer (the body background color), and that change appears, but the fonts are still default.

    I don’t know what it means, but when I look at the frame source in the Customizer, there are 15 instances of “Rammetto”, but when I look at the live page source, there are only 11.

  5. 4 months, 20 days ago Andrew Misplon Hi, I Work Here

    I think we’re halfway to figuring this out. If possible, please, take a screenshot of your font settings in the Customizer and upload it to imgur.com or any online site/source and send us the link. We’ll take a look and find a solution ASAP.

  6. 4 months, 20 days ago theotherstephen

    I noticed that the font was set to a subset of Latin, so just to try, I set that back to default. No effect. I just mention it because I took two screenshots.

    https://sicknwrongfilm.com/fonts1.png

    https://sicknwrongfilm.com/fonts2.png

  7. 4 months, 20 days ago Andrew Misplon Hi, I Work Here

    Thanks for the screenshots and updates. There is a 403 error in the browser console when I view the home page.

    I think I know where the issue is. It looks like we’re pulling Helvetica into the Google Fonts import link. Until the next Corp update, please, try switching the settings using Helvetica Neue to Roboto which is perhaps the closest. Does that temporarily resolve the issue?

  8. 4 months, 20 days ago theotherstephen

    That did it, thank you! Would you guess I’d be safe if I stuck with all Google fonts? I know you probably can’t promise that.

  9. 4 months, 20 days ago Andrew Misplon Hi, I Work Here

    Thanks for your understanding. I’m glad to hear the change helped. The issue you’ve reported won’t occur when only Google Fonts are used. When the next Corp update is released the issue will be resolved and any font combination can be used. Thanks for your help.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More