Home>Support>Editing page doesn’t update and instead redirects to posts dashboard /wp-admin/edit.php

Editing page doesn’t update and instead redirects to posts dashboard /wp-admin/edit.php

Hey team,

I have a client website that uses SiteOrigin page builder with the classic editor plugin installed. We are running the latest version 2.12.0 and the latest version of WordPress 5.7.1

Recently, our SEO provider brought a bug to our attention. We are currently unable to update a page after we have edited it. This is within the content of the Page Builder, but also when we try to update the meta description for the page in the Yoast SEO meta box. I.e. no matter what you try to edit on the page, when you click update it does not save, and instead redirects us to the /wp-admin/edit.php page in the backend.

I have tried switching themes, and deactivating all of the plugins. What I found was that when the Classic Editor plugin is activated with no other plugins… the error occurs. Removing the Classic Editor plugin fixes the problem.

However, even when I have deleted the Classic Editor plugin, once I activate SiteOrigin Page Builder the problem occurs again because it appears to be using the classic editor even though that plugin is deactivated.

Could you support with guidance on fixing this issue?

Warm regards,
Jonathan.

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 5 months, 15 days ago Andrew Misplon Hi, I Work Here

    Hi Jonathan

    Thanks for reaching out.

    To confirm, the issue is occurring with a default theme activated like Twenty Twenty and only the Classic Editor plugin activated? If so, please, could you try debugging in that configuration?

    When the issue occurs, is there anything noteworthy happening in the console?
    https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

    After the issue occurs, is there anything reported in the debug.log file? If debug logging isn’t enabled you can enable it in the WordPress wp-config.php file.
    https://www.wpbeginner.com/wp-tutorials/how-to-set-up-wordpress-error-logs-in-wp-config/

    There are quite a few forum threads reporting this same issue on the WordPress.org forums and others. I haven’t seen a single solution yet. It sounds like it might be hosting-related. If that is the case, having the debug.log line items will make opening a support case a bit easier.

  2. 5 months, 15 days ago JonathanBaldwin

    Hey Andrew,

    I did test with the Twenty Twenty-One Theme and classic editor and experienced the same issue.

    I will contact my hosting provider and see if he can see anything on his end.

  3. 5 months, 14 days ago Andrew Misplon Hi, I Work Here

    Hi Jonathan

    Thanks for confirming.

    Reading similar threads it sounds like mod_security or a similar module might be an issue. Please, let us know how you get on.

  4. 5 months, 11 days ago JonathanBaldwin

    Hey Andrew,

    Thanks for your support. It did end up being a server issue, that was being triggered by any SiteOrigin content that was longer than 8 rows. Migrating the websites to a different server fixed the issue in our case.

  5. 5 months, 11 days ago Andrew Misplon Hi, I Work Here

    Hi Jonathan

    Thanks for the update. We’re really glad to hear you’ve resolved the issue and can proceed as required.

    If any SiteOrigin questions arise in the future, please, let us know.

    Cheers for now :)

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More