Home>Support>Edit Add Site Origin Icon and Text gives error

Edit Add Site Origin Icon and Text gives error

I tried to customize the header on my site and received this error message:

Site Origin Icon and Text

There has been a critical error on your website. Please check your site admin email box for instructions.

Please help.

Frank Grabo
SixPackTech.com

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 2 years, 27 days ago Andrew Misplon Hi, I Work Here

    Hi Frank

    Thanks for reaching out.

    I’m unable to replicate an error with the SiteOrigin Icon and Text widget. It would be better, if possible, to switch to the SiteOrigin Features widget, part of the SiteOrigin Widgets Bundle.

    If you have a technical background, one option would be to enable debug to see what the error is, here is how https://www.wpbeginner.com/wp-tutorials/how-to-set-up-wordpress-error-logs-in-wp-config/.

    Another option would be to see if a plugin conflict is a problem. Temporarily deactivate all plugins not authored by SiteOrigin, does the issue resolve in this state?

    If the Site Origin Icon and Text widget is inserted in a known location, you could also try replacing it with a SiteOrigin Features widget and see if that resolves the issue.

  2. 2 years, 26 days ago fcgrabo

    Thanks.

    I'll give it a try and report back.

  3. 2 years, 26 days ago Andrew Misplon Hi, I Work Here

    Sounds good, chat then :)

  4. 2 years, 23 days ago fcgrabo

    Sorry for the delay.

    First, I deactivated all the plugins and then tried *Customize* under the
    Themes heading in Appearance. No change. Still get the error code.

    The SiteOrigin Widgets Bundle was new to me. It didn't come with my initial activation of Origami from a bunch of years ago but I found it and activated it. There are a lot of features there and it's confusing as to what pertained to my customize problem.

    You wrote:

  5. 2 years, 23 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update. Which version of Origami are you using?

  6. 2 years, 23 days ago fcgrabo

    Screen shows Origami version 1.7.7.

    FG

  7. 2 years, 22 days ago Andrew Misplon Hi, I Work Here

    Thanks for checking, that’s correct.

    To confirm, this is the location you’re trying to edit https://imgur.com/a/ue1SZDp and at that location, you’re seeing an error?

    If you have a technical background, please, enable debugging, there should be error specifics in the log file.
    https://www.wpbeginner.com/wp-tutorials/how-to-set-up-wordpress-error-logs-in-wp-config/

    If that isn’t possible, perhaps install Query Monitor https://wordpress.org/plugins/query-monitor/. If there are relevant errors in red, please, take a screenshot, upload to imgur.com or similar and send us the link.

    Thanks

  8. 2 years, 21 days ago fcgrabo

    Hello again.

    I've enabled debugging.
    I tried the "customize" selection and received the error message.
    Found the debug.log file and enclosed a copy below.

    Hope it helps.

    Thanks again.

  9. 2 years, 21 days ago Andrew Misplon Hi, I Work Here

    Hi Frank, super, thanks for the effort. The forum doesn’t support email attachments. Any chance you could upload the log contents to pastebin.com or the file to WeTransfer.com or any cloud site and send us the link?

  10. 2 years, 21 days ago fcgrabo

    Wow. Didn't know about this.

    Look at this link. <https://pastebin.com/kdLrxxVi&gt;

    FG

  11. 2 years, 20 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update.

    The last line is a memory exhausted error. You can increase the PHP memory available to WordPress yourself, here is how https://www.wpbeginner.com/wp-tutorials/fix-wordpress-memory-exhausted-error-increase-php-memory/. However, it’s a bit of a technical task. An easy option is to reach out to your hosts and ask if they can please, increase PHP memory for your site to 256M.

  12. 2 years, 20 days ago Andrew Misplon Hi, I Work Here

    I forgot you’ve already edited your wp-config.php file to enable debugging. Please, see the tutorial above, it’s a single line that needs to be added to set PHP memory, hopefully that helps the issue. Please, let me know how it goes.

  13. 2 years, 19 days ago fcgrabo

    I added the line according to the tutorial and then I couldn't login to the site. I deleted the line that I added and verified that I could login.
    I then called the host tech support. After about 7 minutes they told me that they increased the PHP memory to 256M.
    After the call, I went and looked at the wp-config.php file and could not see any difference.
    Trying again to "customize" from the WP Appearance menu gave me the same error message.
    I cannot find a window on cPanel that shows me how much memory is allocated to php.

    I'll probably call HostGator on Wed. and pick their brains a little bit.

    Also:
    https://pastebin.com/XURm4zGN

    Thanks.

  14. 2 years, 19 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update.

    There are a few ways to increase PHP memory, hosts wouldn’t make the change via WordPress which is why there wouldn’t a change to the wp-config.php file. They’d use one of the other two methods described in the tutorial, php.ini file, or perhaps via the htaccess file.

    You can use https://wordpress.org/plugins/server-ip-memory-usage/ to check PHP memory.

    Was there an error produced when you changed the memory allocation in your wp-config.php file?

  15. 2 years, 19 days ago fcgrabo

    After editing wp-config.php to include the statement: define(
    'WP_MEMORY_LIMIT', '256MB' );
    I'm still getting the error message upon trying to customize the theme.

    I don't know if I'm doing something wrong or not. PHP context is a mystery to me.

    Thanks for staying with me.

  16. 2 years, 19 days ago Andrew Misplon Hi, I Work Here

    Hi Frank, please, email me via our premium support desk on [email protected]. I’ll reply when I’m online tomorrow and try to speed this up and the issue resolved. Thanks. Sorry for the hassle.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More