Home>Support>Dco Comment Attachment Plugin Issue

Dco Comment Attachment Plugin Issue

I’m trying to use this plugin DCO COMMENT ATTACHMENT but it doesn’t work. Although it’s working on the WordPress default themes. So I think the problem is in the Corp Theme which I’m using. The plugin supposed to attach files and images to comments. But it looks like the theme doesn’t use default WordPress functions to work with comments. Can you help me to understand how it works?

Thank you!

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 7 days, 8 hours ago Andrew Misplon Hi, I Work Here

    Hi Maxim

    Does this plugin work in Twenty Sixteen or Twenty Nineteen themes for you? It only seems to work in Twenty Twenty when I test it.

  2. 7 days, 7 hours ago Andrew Misplon Hi, I Work Here

    I’ve taken a quick look around, I’m not seeing where the issue is. Please, can you consider opening a support topic with the plugin author? The Corp comments template is available on GitHub https://github.com/siteorigin/siteorigin-corp/blob/develop/comments.php. If you agree that the issue persists with Twenty Sixteen and Twenty Nineteen then it would suggest that it isn’t just Corp that’s impacted. We’re happy to help, we just need a little more info.

  3. 6 days, 22 hours ago Maxim Kosolapov

    Hi! Thanks for your response! So the plugin is definitely working in Twenty Seventeen, Twenty Nineteen and Twenty Twenty. I’m pretty sure that the problem is in the Corp theme comments function because I tried the other plugin — WP Discuz and it doesn’t work as well. But is works on all of the default themes.

    I also tried to disable all the other plugins but had no luck. So that’s why I suppose that the problem is in the theme.

    Thank you for your help!

  4. 6 days, 22 hours ago Maxim Kosolapov

    I mean the DCO plugin works but I can’t attach any file or image to the comment. And the WP Discuz plugin doesn’t work at all. It shows up in the comment section but all the functionality is missing. Maybe there is AJAX or JQuery conflict?

  5. 6 days, 21 hours ago Maxim Kosolapov

    Hey! I’m so sorry! I solved the problem! It was totally my fault. It turned out that I deleted footer php code from single.php file and that’s what caused all the issues.

    Again I’m sorry!

    And also I’ve been using your themes for years and your work is amazing!

    Thank you and have a wonderful day!

  6. 6 days, 8 hours ago Andrew Misplon Hi, I Work Here

    Hi Maxim

    Super, I’m really glad to hear you’ve made progress. Thanks for keeping us updated and for your support.

    All the best with your website :)

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More