Home>Support>Conflict with shortcode [content_block id=xxxxxxx] of plugin “Content Blocks (Custom Post Widget)”

Conflict with shortcode [content_block id=xxxxxxx] of plugin “Content Blocks (Custom Post Widget)”

Hello,

I have a conflict with the shortcode [content_block id=xxxxxxx] which display all the content of page instead of content block. If I disable the plugin “Siteorigin builder” then the content of the block is correctly displayed.
Do you have please a solution about this conflict ?

Regards,

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 29 days, 18 hours ago Andrew Misplon Hi, I Work Here

    Hi, thanks for reaching out.

    Please, send a link to the plugin in question; we’ll take a look and go from there.

  2. 25 days, 14 hours ago neobiz

    Hi Andrew,

    Thanks for your reply, you can found following the link of the plugin in conflict : https://wordpress.org/plugins/custom-post-widget/

    Regards,

  3. 25 days, 10 hours ago Andrew Misplon Hi, I Work Here

    Hi, thanks for the link. I’m not sure I have a page matching my test block. Do you have many instances of the Custom Post Widget shortcode deployed on your site? I wonder if the issue might be resolved by switching to the slug-based shortcode. For example, my content block is called Test with a slug of test. The shortcode is:

    [content_block slug=test]

  4. 24 days, 16 hours ago neobiz

    Hi Andrew,

    Thanks for your reply, I have only one instance of the custom post widget but this instance is displayed on all page of the website. The short code works only on the home page, this short code display a simple text but on the other page it displayed all the content of the page. In this cas, the content is duplicated and displayed twice. I have already change the use of the short code by using a different slug or a different ID, but the error is still present.

    Regards,

  5. 24 days, 9 hours ago Andrew Misplon Hi, I Work Here

    Thanks for trying to change from an ID to a slug. If possible, please, try checking for a working baseline. Does the issue persist if you temporarily deactivate all plugins except for Page Builder and Custom Post Widget? It’s a quick test to see if perhaps there is a third-party plugin involved. Thanks again. Andrew

  6. 23 days, 12 hours ago neobiz

    Hi Andrew,
    Thanks for your reply, I try to desactivate all plugins except for Page Builder and Custom Post Widget but the problem is still present.
    I tested with another theme (twenty Nineteen) and the problem disapear, so the problem is my theme because the shortcode is added in the file header.php :

    Do you know if there is a problem with Page Builder by customizing theme with the file header.php ?

    Regards,

  7. 23 days, 8 hours ago Andrew Misplon Hi, I Work Here

    Thanks for the update. Is it just static text you’re loading in the header? Which theme are you using?

    Do you know if there is a problem with Page Builder by customizing theme with the file header.php ?
    There is no general issue of this nature with Page Builder.

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More