Home>Support>Can’t edit SiteOrigin widgets

Can’t edit SiteOrigin widgets

Hello,

I’m having some problems with widgets on North theme and Mono site pack, which I installed straight after installing WordPress.

I can’t edit SiteOrigin Headline or SiteOrigin Features widgets which I earlier installed, and some changes I make to SiteOrigin Headline widgets no longer take effect.

When editing widgets, the little down arrow (and other icons) in Hero frames > Frame and Feature is unresponsive

When I add a new SiteOrigin Headline or Features widget, I see more options in the widget edit screen, however all buttons are unresponsive, and under Icon I see “Icon The site is experiencing technical difficulties.”

I tried installing Widgets for SiteOrigin plugin (which came pre-installed with the Mono site pack, but I had earlier removed in an attempt to debug). This crashed WordPress (blank screen with “The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.”)
Renaming/removing this plugin’s folder via FTP resolved that issue.

When doing the above, the only plugins activated were Page Builder by SiteOrigin and
SiteOrigin Widgets Bundle.

Other less serious errors I’m experiencing are, sometimes, the page not saving (Update remains greyed out), and the inability to load prebuilt layouts, when Siteorigin Widgets Bundle is activated.

Any help greatly appreciated!

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 14 days, 12 hours ago Andrew Misplon Hi, I Work Here

    Hi

    Hi, thanks for reaching out. The errors described could be JavaScript related. It sounds like you’ve already been troubleshooting. To be sure, please try the plugin conflict test outlined below to check if a working baseline can be found.

    This sounds like it could be a plugin conflict issue. Can you try disabling all non-SiteOrigin plugins and see if this fixes the issue? You’ll need to clear all your caches after disabling your plugins.

    If it does fix the issue, then try re-enabling your plugins one by one until the issue comes back. This procedure will help diagnose which plugin is causing the issue.

    Once we know that, we’ll be able to look at what might be causing the conflict and either solve the problem or help you find an alternative plugin.

    If you aren’t using a SiteOrigin theme, then you can also try temporarily switching to one of the default WordPress themes to see if the issue is theme related.

  2. 13 days, 21 hours ago robijon

    Hi Andrew,

    Thank you for your reply.

    This behaviour occurs when the only plugins active are the two SiteOrigin plugins mentioned above.
    Clearing the cache has no effect.
    Switching to a default theme (I tried Twenty Seventee) has no effect.

    Thanks,

    Robin

  3. 13 days, 21 hours ago Andrew Misplon Hi, I Work Here

    Thanks for the feedback. When Page Builder is unresponsive, please check the JavaScript console and let us know what errors, if any, are presented.

    https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

  4. 13 days, 20 hours ago robijon

    With /wp-admin Edit Page open, in Firefox I don’t see any errors in Web Console.
    In Chrome and Safari (JavaScript Consoles) i see:
    Failed to load resource: the server responded with a status of 500 (Internal Server Error)

  5. 13 days, 20 hours ago Andrew Misplon Hi, I Work Here

    Thanks. What resource failed to load, there should be more information in the console line item. On the right, there will be information letting you know what file wasn’t loaded. You might have to hover over the line on the right to see the full path.

  6. 13 days, 20 hours ago robijon

    Thanks.
    The following failed to load:
    in Chrome
    …/wp-admin/admin-ajax.php?_panelsnonce=427826b277:1
    in Safari
    …/wp-admin/admin-ajax.php?_panelsnonce=61046ca802

  7. 13 days, 19 hours ago Andrew Misplon Hi, I Work Here

    Thanks. It sounds like the server is rejecting the request. Please, reach out to your hosting provider and ask if mod_security (or an equivalent is installed). If so, are you getting blocked? You may need to provide your hosting provider with an account so they can run some tests.

  8. 13 days, 18 hours ago robijon

    The hosting provider’s response was:
    “Mod_security is already enabled for this site. We do fully support ajax. But we cannot provide debugging support for this. Please contact the script vendor or any developer who can fix the issue.”

    Many thanks for your help getting this far. I’ll see if I can find someone to help me debug.

  9. 13 days, 18 hours ago Andrew Misplon Hi, I Work Here

    Thanks for the update. I’m not sure how this can be solved without the help of your hosting company. Usually, an error like this would be resolved by adjusting the ModSecurity rules to prevent the WordPress core admin-ajax file from being blocked.

  10. 13 days, 17 hours ago Andrew Misplon Hi, I Work Here

    If you have access to ModSecurity, you could whitelist yourself but if you’re on shared hosting you won’t have access to the module. This is why hosting support usually helps with ModSecurity error logs and whitelisting, because client-side access isn’t available.

    https://www.jasonkingstudios.com/blog/apache-mod_security-whitelisting-wordpress/

  11. 13 days, 16 hours ago robijon

    In cPanel I only have the option to turn ModSecurity on or off, not adjust the rules.
    When I asked about whitelisting, the host replied: “currently the admin-ajax is not being blocked by mod sec and the script should be fully operational and usable on the server.”

  12. 13 days, 14 hours ago Andrew Misplon Hi, I Work Here

    Thanks for the update. You could try temporarily deactivating ModSecurity and then testing the problem. That would be a way of testing that component yourself.

  13. 13 days, 13 hours ago robijon

    I got some more help troubleshooting, and it turns out the problem was insufficient PHP memory on the domain. Increasing it (cPanel > MultiPHP INI Editor) resolved the issue.

    An example of the error messages in error_logs is:
    [08-Jun-2019 09:59:53 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 62765 bytes) in /home/……/wp-includes/wp-db.php on line 1550

    Thank you very much for your help fixing this.

  14. 13 days, 13 hours ago Andrew Misplon Hi, I Work Here

    Super, glad to hear you’ve made progress, that’s great news. Thanks for keeping us updated. All the best :)

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More