Home>Support>Audio player does not stop when next clip played

Audio player does not stop when next clip played

I have created a site for a musician using Vantage theme and the Block editor. On the Audio page I have several samples of the musician’s audio, using the ‘Audio’ block. When you go to the page and click on a player to listen to one sample, that works fine, but when you move on to a second player and click that, the first player continues playing too – not a good sound.
This is the link to the page so you can see the problem https://domhaslam.com/audio/.
I have created similar pages on previous sites using Classic Editor and the Audio widget in a Site Origin layout without this problem but cannot get this to work on this site.
I tried creating a new page using the Classic editor and Page Builder but when I inserted the Audio player, I can only see the URL of the audio clip, not the audio player itself.
This is the link to that Classic page. https://domhaslam.com/audio-classic/
What is going wrong please?

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 5 months, 3 days ago Andrew Misplon Hi, I Work Here

    Hi Janie

    Thanks for reaching out.

    I’m getting the same result as you when I use the core WordPress Audio Widget with an externally hosted file. The issue seems to resolve when I use a sample file (https://samplelib.com/sample-mp3.html) that’s self-hosted. You could perhaps self-host the file to resolve this issue.

    I’m not sure this problem relates to Page Builder. If you wanted to check you could deactivate all SiteOrigin plugins, temporarily switch to a default theme like Twenty Nineteen and then try the Audio Widget in a theme widget area.

  2. 5 months, 2 days ago janiemann

    Hi Andrew,
    Thank you so much for your reply. I am afraid I don’t understand what you mean by the file being ‘self-hosted’. How do I do that? I currently have the audio files uploaded to the Media library of the site.
    I have also done an experiment using another (much simpler) site that I have just created, it is using the same version of WordPress but I created it using the Classic Editor. I created an audio page using the Classic Editor (http://julietbankes.co.uk/audio-test/ ) This worked perfectly.
    I then switched to using the Block editor on this site and created another page (http://julietbankes.co.uk/Audio-Test-Block/) This page has the original problem in that the first player doesn’t stop.
    I then created a third page using the Block editor but inserted a Site Origin layout block and then your Audio widget (http://julietbankes.co.uk/audio-test-site-origin-block/) You will glad to hear that this worked perfectly.
    But when I try that option on the Music site (https://domhaslam.com/audio-site-origin-block/) something is stopping the audio player from displaying, all you see is the URL of the audio clip.
    In summary, I don’t think it is a Site Origin problem as your Layout Block solves the problem of the basic Audio Block not working properly.
    I think there must be something else on my music site messing with things and I’ll have to try disabling stuff.
    If you have any other brainwaves, I’d be VERY grateful!

  3. 5 months, 2 days ago Andrew Misplon Hi, I Work Here

    Hi Janie

    The current sound file is hosted on another domain. Please, try uploading the file to MediaAdd New within the current domain or via the Audio Widget and see if that helps.

    I’m glad to hear the Audio Widget works in Page Builder on the test site. The Audio Widget is a core WordPress widget, it isn’t authored by SiteOrigin. A minor point but I thought I’d mention it anyway.

    Thanks for the detailed testing information and the effort; I appreciate it.

    On the following page https://domhaslam.com/audio-site-origin-block/. Please, try ensuring that the audio file is served from domhaslam.com and not from https://secureservercdn.net/. Does that make any difference? This might not solve the problem but let’s rule it out to be sure.

  4. 5 months, 1 day ago janiemann

    Hi Andrew,
    Once again thank you so much for taking the time to respond with suggestions and information.
    I have checked the audio files and they are all in fact (I think!), hosted on http://www.domhaslam.com, for example https://domhaslam.com/wp-content/uploads/2022/02/1.-The-Elephant-Man.mp3.
    I had used Media – Add New for the uploads.
    The URL http://secureservercdn.net etc which shows on the audio-site-origin-block page instead of the actual Audio player is a mystery to me maybe something to do with the audio player itself?
    I have tried disabling plug-ins one by one and that makes no difference so I think I am going to have to re-make the site, only using Site Origin plug-ins which seem to work well on my other trial site, starting with the Audio page and see if I can make it work.
    I do appreciate all your help and also want to say how much I like Vantage theme and your Site Origin plug-ins, a great help to a novice web site designer like me.

  5. 5 months, 1 day ago Andrew Misplon Hi, I Work Here

    Hi Janie

    Thanks for your reply and support; it’s most appreciated.

    It looks like you’re perhaps using a CDN.

    Is there any change if you use the Audio Widget and use the Insert From URL option within the widget:

    https://imgur.com/a/UR8iCvZ

    Try inserting the URL https://domhaslam.com/wp-content/uploads/2022/02/1.-The-Elephant-Man.mp3. I’m not sure if the site will still load the URL from the CDN. Perhaps not?

  6. 4 months, 29 days ago janiemann

    You are a genius! By using 'Copy URL to Clipboard' for the clip, then using the 'Insert from URL' option in the Site Origin Audio widget as you suggest, it displays the Audio player and only plays one clip at a time.
    I am still puzzled as to why the CDN gets involved – I have seen it said that this is a GoDaddy thing and I did use one GoDaddy plug-in initially.
    But I can now re-make the audio pages of the web site, thank you so much for your support.

  7. 4 months, 29 days ago Andrew Misplon Hi, I Work Here

    THanks for the update. I’m glad to hear you’ve made progress.

    If you haven’t setup a CDN yourself then you could perhaps ask your hosts if the CDN is added at a hosting level.

    All the best with the rest of your project.

    Kind regards

    Andrew

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More