Home>Support>Add Hero Image in Post Page

Add Hero Image in Post Page

By lmk83, 18 days ago. Last reply by lmk83, 2 days ago.

Good Morning to all

I am using North Theme for my website ( www.volt24.gr ) and I set a page as post page for news feed, etc. I am trying to add a hero image above the posts in this page but the hero image widget doesn’t appear in the page.

So my question is if there is a way or solution to display a hero image adove the posts?

Thank you in advance.

This is a free community support forum. Replies are not guaranteed. If you need professional email support, please purchase a SiteOrigin Premium license.

  1. 15 days, 18 hours ago Alex S Hi, I Work Here

    Hi Lmk83

    Unfortunately, there’s no way to control the WordPress defined posts page at this time.

    I would recommend creating a custom post loop to do this (there’s no disadvantage to doing this and you’ll get more control over your blog page). Please navigate to WP AdminSettingReading and set Posts Page to -Select-.

    Please open your post page in the editor and add a new row below the hero widget and add a Post Loop widget. Set the desired template and then save. How does that look?

  2. 11 days, 19 hours ago lmk83

    Good Morning Alex S

    I tried to insert a post loop widget in a row and it seems it works fine for the purpose I want. But when I add a post loop in a row the sidebar appears, despite of setting Page Layout -> No Sidebar.

    Thank you in advance

  3. 9 days, 21 hours ago Alex S Hi, I Work Here

    Hi Lmk83,

    Do you have a public URL where we can take a look at what’s going on?

  4. 8 days, 17 hours ago lmk83

    Good Morning Alex S,

    I’m sorry for the delayed response. The post-page is on developement mode and I’ve set on a local machine, for now. I want to run some tests before I upload to my website. However, I attached a screenshot for the bug in the link below:

    Screenshot_Page-News

    I marked the troubled area with a red border. The page settings are:

    Page Layout -> No Sidebar
    Menu Position -> Default
    Page Title -> False (Unchecked)

    Hero Widget Row Settings:
    Row Layout -> Full Width Stretched

    Post Loop Widget Row Settings:
    Row Layout -> Standard

  5. 8 days, 17 hours ago lmk83

    My apologizes,

    This is the right link for the screenshot

    Screenshot-PageNews

  6. 8 days, 15 hours ago Alex S Hi, I Work Here

    Hi Lmk83,

    What is the page template set to? To check this, please open the pictured page in the editor and then find the Page Attribute box. Ensure the Template is set to Default.

  7. 7 days, 20 hours ago lmk83

    Good Morning Alex S

    I have no ‘Template’ option in Page Attributes section as you can see, in the image below. It is North Theme Free version.

    Screenshot_PageAttributes

  8. 7 days, 14 hours ago Alex S Hi, I Work Here

    Hi Lmk83,

    Would it be possible for you to create a temporary admin account for us so we can log in and take a look?

  9. 7 days, 14 hours ago Private Message - Alex S Hi, I Work Here

    This is a private message.

  10. 6 days, 18 hours ago lmk83

    Good Morning Alex

    I tried to create the post page online to my website (). I have just realized that in online this issue doesn’t appear at all! This is very odd.

    I created some draft posts for examples and I tested and it works fine by now, as we have discussed. I tried it again in ‘localhost’ machine but there is no result.

    So, shall I create an account for you to take a look? I am considering about that there is no ‘Template’ option in ‘Page Attributes’ section. Is it important for the whole template? Otherwise, consider it is done

  11. 2 days, 20 hours ago Alex S Hi, I Work Here

    Hi Lmk,

    That section is only important if you wish to use it. Do you maybe have a really old version of SiteOrigin North locally?

  12. 2 days, 19 hours ago lmk83

    Hi Alex S,

    I installed both in live server and localhost 1.3.19 version. Nonetheless, I created a new account for you as you indicate in the post above.

    The blog page is not published in the main menu but it is available in page section titled as ‘Blog’.

    Please let me know when you take a look on it. If it is OK, probably my local account needs a fresh installation.

    Thank you in advance.

  13. 2 days, 19 hours ago Private Message - WordPress

    This is a private message.

  14. 2 days, 18 hours ago Alex S Hi, I Work Here

    Hi Lmk,

    Unfortunately, looking at the website without issue won’t help us work out why it’s not working on the other site.
    If this issue persists after you’ve migrated the website to a server, let me know and I’ll be able to look into it then.

    Sorry mate. :(

  15. 2 days, 18 hours ago lmk83

    OK Alex,

    Don’t bother it’s OK. If I meet an issue while developing the post on live-server, I will post an another subject.

    So, consider this post as ‘Answered’.

    Thank you for your assistance and sorry for this inconsistency.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More