Home>Support>100 Maps stopped working, worked with restore, then blew up

100 Maps stopped working, worked with restore, then blew up

I had a 100 maps that stopped working. I edited a single page and only page worked. I did not make any edits. Just opened the map and clicked restore and saved. I did this for 4 pages and each worked. Other pages did not not show map. As I edited the next page map I clicked to ‘ignore the restore’ that the siteorigin plugin was highlighting, just to see what would happen. This time the map did not show. So When I tried to edit that block there was nothing to edit. No way to revert back to when it was working. But then all pages that were NOT working suddenly stopped showing this “restore’ option and were permanently map disabled. Then – curiously the 5 pages I edited and were working fine were now requesting to ‘restore’ again. I clicked ok and it broke the map on that page.
SUMMARY
‘Restore’ fixed maps on first 5 pages, then when I clicked to ‘ignore’ the ‘restore’ option on the next edit (page 6) the map did not show. Then other 90 pages stopped showing the restore option in edit mode. The only pages that show it were the working pages and now clicking restore disabled select page.

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 5 months, 2 days ago Andrew Misplon Hi, I Work Here

    Hi, thanks for reaching out.

    When able, please, send us a page export from a map that isn’t working. It sounds like you’re using the Block Editor. If so, please, edit an impacted page, click the three dots at the top right and then click to view the code view of the page. Please, copy the page code to a text file, upload it to wetransfer.com, Dropbox, Drive, or any similar online location and send the link. We’ll take a look locally and advise from there.

  2. 4 months, 29 days ago freecaper

    Hello Andrew

    Thanks for your response.
    I am unable to follow your instructions. I do not see any '3 dots'.
    However, I made a staging copy of the website and it is replicating the issue.
    I can you access to it with admin + ftp credentials. Will that work?

  3. 4 months, 29 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update.

    * When able, please, try running a plugin and theme conflict test on your staging site:

    – Temporarily deactivate all plugins not authored by SiteOrigin. Does the issue persist in this state?
    – If the issue persists, leave all plugins except those authored by SiteOrigin deactivated. Go to AppearanceThemes and temporarily switch to a default theme like Twenty Nineteen. Does the issue persist?

    Thanks again.

    (We can log in and assist directly within our SiteOrigin Premium support scope.)

  4. 4 months, 29 days ago freecaper

    Toolset blocks plugin (maps) do not work with your product. I have no choice but to use Toolset. It works with everything – and I will be overly concerned if you are the exception. WordPress is not that complicated so you must fix this bug.

    I will buy a premium product if that will help you. The problem is the
    Toolset Blocks plugin break your editor. All other toolset plugins are ok.
    Is Toolset known to break your plugin? It breaks when it is enabled and only maps (nothing else) disappear – However placeholder remains AND the
    Preview of Map (in edit mode) looks fine. The Toolset blocks plugin provides the database that is the purpose of this website. Directory of lawyers bostonlawyers.com.

  5. 4 months, 29 days ago Andrew Misplon Hi, I Work Here

    Thanks for the update, glad to hear you’re making progress.

    On your staging site, does the issue persist with the following setup:

    * SiteOrigin Widgets Bundle and Page Builder by SiteOrigin activated (if you use Page Builder).
    * Toolset Blocks plugin activated.
    * A default theme like Twenty Nineteen.

    Does the issue persist with the above configuration?

  6. 4 months, 29 days ago freecaper

    Thanks for your reply. I just got an update from toolset. They added some code snippets I have below

    1. The Issue was a JS error below:

    bootstrap.min.js?ver=5.8.2:6 Uncaught Error: Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3 at bootstrap.min.js?ver=5.8.2:6 at bootstrap.min.js?ver=5.8.2:6

    jquery.min.js?ver=3.6.0:2 Uncaught TypeError: $element.tooltip is not a function at Object.tooltipInit (scripts.js?ver=5.8.2:1943)
    at HTMLDocument.init (scripts.js?ver=5.8.2:952)

    Uncaught TypeError: Cannot read properties of undefined (reading
    'Constructor')
    at Object.stickyNavbarPadding (scripts.js?ver=5.8.2:59)
    at init (scripts.js?ver=5.8.2:1953)
    2. They JUST NOW applied this "Custom Code" fix but I have yet not checked it out:

    add_action( 'wp_enqueue_scripts', 'remove_toolset_maps_scripts', 20 );
    function remove_toolset_maps_scripts() {
    global $post;

    if($post->post_type == "post"){
    wp_dequeue_script( 'views-map-script' );
    wp_deregister_script( 'views-map-script' );
    }
    }

  7. 4 months, 29 days ago Andrew Misplon Hi, I Work Here

    Super, glad they could assist. Do you have a place to insert the above function?

  8. 4 months, 29 days ago freecaper

    He placed it in a custom code area in Toolset – interactive maps now work in SiteOrigin and the SUGA theme I am using

  9. 4 months, 29 days ago Andrew Misplon Hi, I Work Here

    Glad to hear the issue is resolved. Thanks for sharing the solution from Toolset here.

    All the best.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More