Home>Support>Url being displayed rather than linked

Url being displayed rather than linked

Hi,

SiteOrigin fan here.

On the links page on this site I am using the siteorigin image widget to hold the image and link (in a new window) to the other site. All works well except for http://bible.oremus.org/ which you can see second bottom on the page dispalys the link text and links to http://%3Cspan%20class%3D/ which is dead.

I left this so you can see it. on the lectionary page under worship a different image links to the site though this produced the same problem using the image widget so what you see on the site at the moment uses the siteorigin editor widget.

Theme is Vantage. I can’t work out why. I thought I should let you know in case either I am doing something odd that I can fix, or perhaps there is something odd in code. I really value all you people do.

URL: http://www.cardiffanglican.org.au/cardiff-anglican-parish-st-thomas-church/links/

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 6 years, 11 months ago Andrew Misplon Hi, I Work Here

    Hi Philip

    Can you take a quick look at that widget and check the URL field. Perhaps compare the URL to the URL in the widget below. I think an onclick event is being added but in the case of our broken image/widget the URL is malformed.

  2. 6 years, 11 months ago Philip Barrington

    Hi Andrew,

    I am sure it has something to do with the url bible.oremus.org

    when I tried oremus.org it worked. I thought maybe it is the full stop. So I tried blackswantheology.wordpress.com and that works. I tried oremus.org/bible and that fails as well. I tried wrapping it is quotes and it failed. I am seeing them this morning so I have replaced it with the site origen editor widget for that one where the url works.

    I didn’t see it as an onclick event as it is on the page load, not when you click the image. I don’t know what we did for frustration before we had computers!

  3. 6 years, 11 months ago Andrew Misplon Hi, I Work Here

    Mmm so strange! If you’re happy with the workaround then I’m happy to leave it here for the moment. If you have any further hassles I’d be happy to login and help resolve from there.

  4. 6 years, 11 months ago Philip Barrington

    Thanks Andrew,

    I have tried it on a couple of others sites with vantage and without vantage and with bluehost and without bluehost and it works fine. …. but wait there is more

    I have just nailed the problem. There is a conflict with a plug in I have running – explanatory dictionary where one of the defined terms is bible and that is where the problem is. I will ask them to exclude urls from the way the plug in works.

    Thanks for your help. Sorry to have wasted your time (and mine!)

  5. 6 years, 11 months ago Andrew Misplon Hi, I Work Here

    Nice find! Thanks for letting us know. Hopefully they’re able to assist.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More