Home>Support>SiteOrigin not working after WordPress 5.5. update

SiteOrigin not working after WordPress 5.5. update

Hi there,

on my website https://freshlandscaping.co.za the SiteOrigin isn’t working after I updated WordPress yesterday. Please help! What can I do to make it work again?

Any help is much appreciated.

Kind Regards
Alex

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 1 month, 17 days ago Andrew Misplon Hi, I Work Here

    Hi Alex

    Thanks for reaching out.

    The WordPress 5.5 update has caused many themes and plugins to produce JavaScript errors. Those errors will break anything else on the page that makes use of JavaScript like Page Builder. Try to find a working baseline as follows:

    1. Temporarily switch to the default theme Twenty Twenty.
    2. Temporarily deactivate all plugins not authored by SiteOrigin.

    In that state, does the issue resolve? If so, you can begin adding your theme and then plugins back, testing for the issue after each reactivation to locate the issue. Let us know how it goes.

    Alternatively, if you have a bit of a technical background, try checking the browser console when the issue occurs, here is how https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis. Are there errors in red text? If so, which theme or plugin is producing those errors?

  2. 1 month, 16 days ago Alexandra Lasch

    Hi there

    I am getting this error in red:

    Uncaught ReferenceError: TheLandscaper is not defined
    at bootstrap.min.js?ver=3.4.1:1
    at bootstrap.min.js?ver=3.4.1:1

    What do I do now? I changed the theme to Twenty Twenty and disabled the plugins but nothing worked :-(
    Help!

  3. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Hi, thanks for your feedback. With Twenty Twenty activated and all plugins except for SiteOrigin deactivated, please, take a screenshot of the browser console and upload it to Drive or Dropbox or Imgur.com and send us the link. Thanks again.

  4. 1 month, 16 days ago Alexandra Lasch

    Hi Andrew,

    there is nothing there! Sorry, I am not so good with this. Can I just give you axxess to my website and you can login and have a look?
    Private Snippet
    Private Snippet
    Private Snippet

    I have disabled all the plugins except for SiteOrigin. And activated TwentyTwenty.

    I would really appreciated your help with this. Thanks a million :-)

  5. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Hi, thanks, this is a public forum.

  6. 1 month, 16 days ago Alexandra Lasch

    Oops! Forgot, will change password, once you are finished ;-)

  7. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    I’ve marked the info as private so it can’t be viewed publicly. It was only up for a minute so I don’t there will be an issue.

    We can log in and assist directly within our SiteOrigin Premium support scope but, unfortunately, aren’t able to offer that same level of assistance in our free support scope due to resource limitations.

    It sounds like you’re almost there. With Twenty Twenty activated and only SiteOrigin plugins activated, please, open the console, here is how https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis, take a screenshot and upload it to imgur.com, send us the link. Thanks :)

  8. 1 month, 16 days ago Alexandra Lasch

    https://imgur.com/a/VkEEpSQ

  9. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Thanks. We’re looking for errors when the issue occurs when Page Builder isn’t working.

  10. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    When you have a moment, please, repeat the process but rather take a screenshot when inspecting the console while editing a page where Page Builder is broken. Thanks :)

  11. 1 month, 16 days ago Alexandra Lasch

    Do you want me to take s screenshot while I am in the backend of WordPress or front end as the one I sent is from the front end.

  12. 1 month, 16 days ago Alexandra Lasch

    Do you want me to take s screenshot while I am in the backend of WordPress or front end as the one I sent is from the front end. Sorry confused!

  13. 1 month, 16 days ago Alexandra Lasch

    https://imgur.com/a/9NZz2bT

  14. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Thanks. Is Page Builder working in your last screenshot? It looks in order. From that position of Twenty Twenty with all non-SiteOrigin plugins deactivated, if you enable Black Studio TinyMCE plugin, the page should be normally editable.

  15. 1 month, 16 days ago Alexandra Lasch

    Thanks, I'll check it out. On the road now. Will let you know… Thanks for all your help so far. Much appreciated 🙏

  16. 1 month, 16 days ago Andrew Misplon Hi, I Work Here

    Sure, no problem. In your last screenshot, if you activate Black Studio, it looks like you’ll have a working baseline. If so, you can activate your theme then retest the issue, then reactivate your plugins one by one while retesting for the issue after each activation.

  17. 1 month, 13 days ago Alexandra Lasch

    Good Morning Andrew,

    I found out the Essential Grid Plugin is the one that’s not making the backend work. So I have left that out for now. Should be ok, right?

  18. 1 month, 13 days ago Alexandra Lasch

    I just realised that I actually do need the Essential Plugin to work, as the Maintenance Page won’t work otherwise…. But maybe I can change it so it does not need the grid plugin….

  19. 1 month, 13 days ago Andrew Misplon Hi, I Work Here

    Glad to hear you’re making progress :)

    There are quite a few maintenance mode plugins available, assuming that’s what we’re discussing so it could be an option to use another maintenance mode plugin that doesn’t require the Essential Grid plugin. But I might have misunderstood the situation.

    Alternatively, you can try installing https://wordpress.org/plugins/enable-jquery-migrate-helper/. This plugin adds back a script that was removed in WP 5.5 and might help some plugins as a short term solution.

  20. 1 month, 12 days ago Alexandra Lasch

    Wow Andrew! That plugin worked :-) Thanks soooooooooo much for all your help! I really appreciate it ;-) Have a great day!

  21. 1 month, 12 days ago Andrew Misplon Hi, I Work Here

    Super, glad to hear that helped. All the best with your site. As SiteOrigin questions arise in the future, please, let us know. Cheers for now :)

  22. 1 month, 12 days ago Alexandra Lasch

    Will do, thanks!

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More