Home>Support>SiteOrigin Hero Slider/frames does not stretch on Internet Explorer and Edge browser.

SiteOrigin Hero Slider/frames does not stretch on Internet Explorer and Edge browser.

By Seong W Lee, 2 months ago. Last reply by Seong W Lee, 2 months ago.

On Flash theme, SiteOrigin Hero Slider/frames does not stretch on Internet Explorer and Edge browser.
It is also left aligned when scrolling down.

No issue on Chrome, Firefox, Safari browsers.

Please help!!

Home

Thank you for your support.
– Sean

This is a free community support forum. Replies are not guaranteed. If you need professional email support, please purchase a SiteOrigin Premium license.

  1. 2 months, 19 days ago Alex S Hi, I Work Here

    Hi Sean,

    This appears to be an issue with your theme. Can you please temporarily switch to one of the default WordPress themes to see if the issue is theme related?

    Also, can you try disabling all non-SiteOrigin plugins and see if this fixes the issue? You’ll need to clear all your caches after disabling your plugins.

    If it does fix the issue, then try re-enabling your plugins one by one until the issue comes back. This procedure will help diagnose which plugin is causing the issue.

    Once we know that, we’ll be able to look at what might be causing the conflict and either solve the problem or help you find an alternative plugin.

  2. 2 months, 17 days ago Seong W Lee

    If I temporarily switch to one of the default WordPress themes, the issue does not appear.
    And disabling all non-SiteOrigin plugins does not fix the issue.

    What should I do? Can you help?

    Thank you so much for your support.

    – Sean

  3. 2 months, 16 days ago Alex S Hi, I Work Here

    Hi Sean,

    Unfortunately, based on the results of your tests, this appears to be a general compatibility issue with your theme. I’ll log this compatibility issue for testing. I would recommend reaching out to your theme developers to report this issue also.

  4. 2 months, 16 days ago Seong W Lee

    I contacted the theme developer, and received the following response.


    Hi jakimio,

    If you are having problem with the widget of SiteOrigin plugin then could you please once contact the plugin author. As the problem is related with their widget, hope you understand.

    And let us know if you have any problem related with our theme and plugin.

    Thanks!
    ThemeGrill Support Team

    Is there a way to solve this problem?
    Please help.

    Thank you.
    – Sean

  5. 2 months, 16 days ago Alex S Hi, I Work Here

    Hi Sean,

    To clarify, did you state that this issue only occurs when their theme is being used? I ask as that points to this being a theme issue rather than a general issue by us.

  6. 2 months, 15 days ago Seong W Lee

    Yes, I did as follows.
    —-
    Hi Nima,
    I contacted the SiteOrigin plugin author, and the following results were obtained from the author’s test request.

    <>

    And I got this message from the author.

    <>

    Can I get any help?
    – Sean

    —-

    And I received the following response today.

    ———–
    Hi, Jakimio

    After going deep into the issue. Noticed that Siteorigin’s Page Builder went to flexbox on version 2.5. Which is partially supported by IE. Also, Older version of Edge tends to have some issues with flexbox.

    Please, try updating Edge and IE as I couldn’t replicate the issue on the newer version of Edge and IE. Further, Please let us know if that fixes your issue.

    Best Regards
    Sanjeev Shrestha
    ThemeGrill Support Team

    ————

    However, updating the web browser did not help.

    What should I do?

    Thank you so much for your support and time.
    – Sean

  7. 2 months, 15 days ago Seong W Lee

    Sorry for the missing contents between angle brackets.
    Please see below.

    ——
    Hi Nima,

    I contacted the SiteOrigin plugin author, and the following results were obtained from the author’s test request.

    If I temporarily switch to one of the default WordPress themes, the issue does not appear.
    And disabling all non-SiteOrigin plugins does not fix the issue.>>

    And I got this message from the author.

    Unfortunately, based on the results of your tests, this appears to be a general compatibility issue with your theme. I’ll log this compatibility issue for testing. I would recommend reaching out to your theme developers to report this issue also.>>

    Can I get any help?
    ——

    Thank you.

    – Sean

  8. 2 months, 13 days ago Alex S Hi, I Work Here

    Hi Sean,

    Please navigate to WP AdminSettingsPage Builder and open the Layout tab. Set Use Legacy Layout Engine to Always and save. How does that look?

  9. 2 months, 12 days ago Seong W Lee

    That “”always use legacy layout engine”” option fixed the issue.

    Can I keep using that option?
    Is there something like a side effect that can appear if I continue to use the option?

    Thank you So much for your help.

    – Sean

  10. 2 months, 12 days ago Alex S Hi, I Work Here

    Hi Sean,

    Yes, there’s no harm in using that setting. You will lose access to a few SiteOrigin Page Builder settings like Cell Vertical Alignment, but that’s sadly unavoidable.

  11. 2 months, 10 days ago Seong W Lee

    Thank you so much for your support.
    – Sean

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More