Home>Support>Possibility of having Thumbnail feature images on Portfolio page linking/opening to Portfolio Sub Pages

Possibility of having Thumbnail feature images on Portfolio page linking/opening to Portfolio Sub Pages

Dear Andrew and Greg, thank you in advance for your gems of wisdom!!!
May I ask if this is possible?
I have a Portfolio page and have then decided to rather create Sub Pages with the different aspects to my Portfolio. I would like to have feature image/thumbnail links on the portfolio page that, when clicked would open to the sub page, in case someone wants to navigate to them via Portfolio instead of the sub page shown in the menu?
I have tried opening the Portfolio page, adding a Visual Editor widget, adding a photo, but when asked where to link it to I am given the options of Media, attachment page, custom URL and none…
I have the following plugins installed:
WP lightbox bank, Black Studio Tiny MC Widget, CPO shortcodes, CPO Widgets, Influence Plus, Page Builder and Site origin Widgets bundle… I had a bit of a crash after installing and editing Simple Coding CSS and Jetpac.
Thank you both for all your help and support, I am so excited to be able to create my own website with your knowledge backing me up,
With kind regards,
Robyn

URL: http://www.robynabreyart.com/

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 7 years, 8 months ago Andrew Misplon Hi, I Work Here

    Hi Robyn

    No problem, hopefully we can help get you sorted ASAP.

    have tried opening the Portfolio page, adding a Visual Editor widget, adding a photo, but when asked where to link it to I am given the options of Media, attachment page, custom URL and none…

    There you could select Custom URL and insert the link of the portfolio page you’re linking to. Right now you have a lightbox plugin opening that same image. I haven’t used that particular plugin so you’d need to see if the lightbox still gets in the way once you’ve added a Custom URL link to the image.

  2. 7 years, 8 months ago Robyn Abrey

    Hi Andrew, thank you so much for your support and patience!
    I have tried to do as you suggest and it seems the lightbox ignores the Custom URL and the photo opens to a blank page and the message “could not open the item. Make sure the path is correct and item exists”
    I am seriously considering re-installing Jetpack so I can center the feature photos with the code you suggested to a previous enquirer, do you think some additional coding in Jetpack would overpower the lightbox and magically solve my request above? (So as to avoid the crash I had last time I will be sure to find out from you EXACTLY where to edit the plugin code!!!)
    Regards,
    Robyn

  3. 7 years, 8 months ago Andrew Misplon Hi, I Work Here

    Jetpack alone shouldn’t cause a problem. Can you bring up to speed, which code did you previously try edit and why? It’s easy to run into issues editing theme or plugin files directly, ideally we’d find another way to do the same thing, whatever the edit was going to accomplish.

  4. 7 years, 7 months ago Robyn Abrey

    Hi again Andrew, I’m sorry about the delay in replying…
    The problem with the code was 100% my error. The first attempt in Jetpack, (following your advice to a client on page three of this blog) worked perfectly to center my feature image, BUT jetpack then blocked my ip address due to a previous virus problem on the site.
    I then disabled jetpack and installed the same code in obviously the wrong place in the plugin Simple Coding CSS, which is when things went pear shaped!
    Below is the code, that worked well…
    I will re-install Jetpack and try again to center the feature images, or upload wider files that will fill the width of the page (what would that measurement be? Please ) Any advice for the thumbnails on the portfolio page opening up the sub pages?
    I hope you are having a wonderful and relaxing weekend,
    With kind regards,
    Robyn

    /* Influence Center Featured Images */
    article.entry .post-thumbnail img {
    margin: 0 auto;
    }

  5. 7 years, 7 months ago Andrew Misplon Hi, I Work Here

    Hi Robyn

    Thanks for the further explanation. I think you’re up to speed now. Basically, a snippet like the below:

    /* Influence Center Featured Images */
    article.entry .post-thumbnail img {
    margin: 0 auto;
    }
    

    That’s a CSS snippet, as long as you insert snippets like that in the Appearance > Edit CSS page that Jetpack Custom CSS provides OR into a plugin like Simple Custom CSS. The Simple Custom CSS I think also provides a menu item under Appearance called Edit CSS.

    It’s best to never edit any theme files via Appearance > Editor, rather leave that link item alone.

    For linking portfolio images to another page. Try this, setup a test page, we’ll just test things out there for now. Using Page Builder OR in the regular Visual tab editor, insert a single image and add a caption. When you insert a single image there is an option in the right column to choose where the image links to, select Custom URL and enter the URL for the page you want the image to link to. See how that goes.

  6. 7 years, 7 months ago Robyn Abrey

    Thank you again for your help Andrew.
    I have installed the Jetpack plugin and all is still well… I have linked it to my WP.com account, entered the code and hey presto, the feature images are centralized! THANK YOU! I hope Jetpack/WP.com don’t block my IP address like last time due to a previous virus problem, but for now all is good!
    As far as other issue of linking a portfolio image to another page… I tried as you suggested and unfortunately was sent to a blank page with message:- could not load item, make sure pathway is correct and item exists
    I am assuming this is due to the ‘WP Lightbox Bank’ plugin overriding other instructions? I am hesitant to disable the plugin as it does ensure the photos in the portfolio open nicely…
    Any advice or way around this would be most welcome.
    http://www.robynabreyart.com/testing/

    With grateful thanks and kind regards, Robyn

  7. 7 years, 7 months ago Magus Hi, I Work Here

    Hi Robyn

    You are correct, this is being caused by the WP Lightbox Bank plugin and the developer is well aware of the issue and is planning on fixing this in a future release. The workaround to fix this at the moment is to remove the class section ‘wp-image-####’ from the post when you insert the image.

    After inserting the image, switch to text mode and find the class section for the image, then delete the phrase ‘wp-image-####’ from the section. Once posted this should now follow the link instead of opening the lightbox.

    Hope this helps

    Magus

  8. 7 years, 7 months ago Robyn Abrey

    Hi Magnus, thank you for your help….!!! :-)
    after a few attempts and removing too much code between the “### ” …
    WOOOOOO Hoooooo….. it worked!!!!
    Thank you, THANK YOU!!!!!
    With kind regards,
    Robyn

  9. 7 years, 7 months ago Andrew Misplon Hi, I Work Here

    Win! Thanks Magus, nice one.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More