Home>Support>not showing read more link?

not showing read more link?

i love sitebuilder no doubt.
But i might have to switch back to my regular html editing in wp.
It seems the read more shorttag is beeing stripped from all my pages i put them into.
Or it shows in the page source but never gets transformed to the read more button.

just leaves it as a comment in the page source but showing up as a read more link?

Any suggestions what might be causing this?
http://www.august-nijs.be/opgelet-onze-blogpagina/

Blog is in the link above.

Best regards,
Kristof

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 8 years, 4 months ago glenn.fielding

    hey did anyone work this out? i have the same problem… adding a READ MORE link in is not working so my blog landing page is crammed with the full posts. PLEASE HELP!

  2. 8 years, 4 months ago Andrew Misplon Hi, I Work Here

    Hi Kristof

    In the next release of Page Builder we’ll introduce a setting to the Post Loop widget that will allow the Read more link.

    In the mean time you can try adding the following to the functions.php file of a child theme:

    function theme_child_fix_more(){
    if(is_front_page()) {
    global $more;
    $more = 1;
    }
    }
    add_action(‘template_redirect’, ‘theme_child_fix_more’);

    If you don’t have an existing functions.php in a child theme you’d need to open the functions.php file with an opening PHP tag:

  3. 8 years, 3 months ago glenn.fielding

    hello! thanks. but that makes no sense to me. has the problem been rectified yet or is there an update coming soon? currently my blog posts all appear on the one page in full with a ‘continue reading’ link after each post. clicking this links to the content already seen with the reply posts at the bottom. surely it should be more simple than that? help! :)) glenn

  4. 8 years, 3 months ago Andrew Misplon Hi, I Work Here

    Hi Glenn

    The issue of read more links not functioning with the Page Builder Post Loop widget hasn’t yet been resolved but will be in the next update.

    This thread discusses a hotfix that can be applied to the functions.php of a child theme.

    However if you’re referring to a regular blog page that isn’t powered by a Page Builder widget then this is a different issue. If that is the case, please open a new support thread.

  5. 8 years, 3 months ago ReneK

    Another option is to add a read more link to the default excerpt. Do this by (setting Post Content to Post Excerpt in Theme Settings / Blog.

    Adding the code below to Functions.php (pref. in child theme) will do the trick and all posts in the Post Loop (pb) will show a nice link to the full post and not the default [..]

    // Changing excerpt more
    function new_excerpt_more($more) {
    global $post;
    return ‘… ID) . ‘”>’ . ‘Read More »’ . ‘‘;
    }
    add_filter(‘excerpt_more’, ‘new_excerpt_more’);

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More