Home>Support>Multiple Map Markers – over 12 and the map doesn’t show them

Multiple Map Markers – over 12 and the map doesn’t show them

By Alex Hunt, 23 days ago. Last reply by Andrew Misplon, 8 days ago.

I am having an issue where once I pass 12 map markers the 13th doesn’t show – if I delete the first then the next one shows etc

I found this thread – but it was closed without resolution:

Multiple markers on map widget: More than 10 markers not showing

Has you fixed this issue yet?
Thanks
Alex

My site: https://safewaterproducts.worldsecuresystems.com/legionella-filter-distributors

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 23 days, 2 hours ago Andrew Misplon Hi, I Work Here

    Hi Alex

    Thanks for reaching out.

    Have you perhaps made progress? I think I can count 16 markers on the map at the moment.

  2. 16 days, 10 hours ago Alex Hunt

    Hi Andrew
    Nope – I can only see 12 – I have uploaded 14 at the moment.
    What do you suggest?
    Thanks
    Alex

  3. 16 days, 6 hours ago Andrew Misplon Hi, I Work Here

    Ok sounds like we’re close. I can see 13. Here is my count:

    Where should the 14th marker be?

  4. 16 days, 6 hours ago Alex Hunt

    The last two are:
    Edinburgh castle – Scotland
    And a castle in Sussex south England

  5. 16 days, 6 hours ago Andrew Misplon Hi, I Work Here

    Ok I only see the one in Liverton, nothing else in the UK. Can you send us an export of the page via LayoutsImport/Export? Then upload the JSON file to https://wetransfer.com/. Any email address can be used. Thanks.

  6. 16 days, 5 hours ago Alex Hunt

    Hi Andrew – I can send you the login if you like?

  7. 16 days, 5 hours ago Andrew Misplon Hi, I Work Here

    Hi Alex, sorry, we’re unable to log in within our free support scope. At times it can be a tough balancing act to keep our support offerings financially viable. Logging in and checking issues or directly assisting has, unfortunately, been shifted over to our email premium support scope. Hopefully, I can find a problem locally or on one of our test servers. I’ll test with a different API key to yours. With any luck, I’ll pick something up that we can use to resolve the problem. Thanks.

  8. 15 days, 6 hours ago Andrew Misplon Hi, I Work Here

    Thanks. I can see in my console we’re getting an overy query limit warning. I’ll chat with Braam our lead developer when he’s online tonight (time zone differences) and come back to you ASAP.

  9. 15 days, 5 hours ago Alex Hunt

    Thanks.

  10. 15 days, 4 hours ago Andrew Misplon Hi, I Work Here

    Hi Alex, I was just reminded of a necessary change made to the Maps widget. To migrate your widget, please open it for approximately one minute, close and save.

    If you’re able to open the browser’s JavaScript console, you’ll be able to see a confirmation once the migration is complete. Here is how to open the console: http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors#Step_3:_Diagnosis

  11. 15 days, 2 hours ago Alex Hunt

    I am not sure what you mean?
    …Go into the page where the siteOrigin Google Maps widget has been inserted and leave it open for 1 minute?
    Then Click Done/Update
    I tried this and don’t see any difference?

  12. 15 days, 19 minutes ago Andrew Misplon Hi, I Work Here

    Hi Alex, did you open the Google Maps widget? The widget will need to be open for about a minute to allow the migration to run. If you open your JavaScript console you can confirm when it’s done. If you’re in Chrome, right click anywhere, click Inspect then click Console, that’s the JS console.

  13. 15 days, 17 minutes ago Andrew Misplon Hi, I Work Here

  14. 15 days, 16 minutes ago Alex Hunt

    Yes i opened the widget – however i dont see any change.

  15. 15 days, 13 minutes ago Andrew Misplon Hi, I Work Here

    Try opening the Maps widget with the JavaScript console open as seen in my first screenshot. You’ll then be able to see if a migration is running.

  16. 13 days, 9 hours ago Alex Hunt

    Hi Andrew
    I left it open for a good few minutes – still no change?

  17. 13 days, 3 hours ago Andrew Misplon Hi, I Work Here

    Thanks for the update.

    * Did you have the JavaScript console open while the widget was open?

    * Could you share the link to the page you’re working on so we can take a look?

  18. 13 days, 1 hour ago Andrew Misplon Hi, I Work Here

    Hi Alex

    Would it be possible for you to create a temporary admin account for us so we can log in and take a look? You can create the account with the following email address:

    Private Snippet

    Just navigate to UsersAdd New in your WordPress admin. Enter siteorigin for the username and Private Snippet for the email address. Make sure you’ve selected Administrator for the role and enabled the Send Password field so we receive the details.

    Once we’re finished taking a look, you can delete this account. We’ll let you know when to do that.

  19. 10 days, 9 hours ago Private Message - WordPress

    This is a private message.

  20. 10 days, 9 hours ago Alex Hunt

    OK- I have done that.
    I am using Safari 12.03 o na Mac if that helps?
    Mac OS Mojave 10.14.3
    Best regards
    Alex

  21. 10 days, 6 hours ago Private Message - Andrew Misplon Hi, I Work Here

    This is a private message.

  22. 10 days, 6 hours ago Andrew Misplon Hi, I Work Here

    Thanks

    There are 16 markers, I can see the page showing over query limit either by 3 or 4 markers, it varies. Taking a look and will come back to you ASAP.

  23. 10 days, 4 hours ago Andrew Misplon Hi, I Work Here

    Hi Alex, the problem is resolved. The SiteOrigin Widgets Bundle wasn’t up to date. I don’t know why an update wasn’t showing at DashboardUpdates. I manually updated the WB then opened the map, the migration ran as expected, your markers are now displayed.

  24. 8 days, 12 hours ago Alex Hunt

    Thanks for your help much appreciated – I and my outsourcer spent several days trying to get it to work – so once again thanks for your help. Will the WB update for future updates?
    Thanks
    Alex Hunt

  25. 8 days, 11 hours ago Andrew Misplon Hi, I Work Here

    Really sorry we couldn’t get to a solution sooner. Perhaps check the version number here: https://wordpress.org/plugins/so-widgets-bundle/ at the end of the month and compare it to yours. We should update the Widgets Bundle before month’s end. If an update isn’t showing at DashboardUpdates you can perhaps look at whether this might be a plugin blocking updates or a hosting level block.

  26. 8 days, 11 hours ago Alex Hunt

    Great!
    Thanks again for your help – Ill go add all the other distributors and remove the castles! lol

  27. 8 days, 10 hours ago Andrew Misplon Hi, I Work Here

    For sure :) Sounds like a plan. Cheers for now.

Please log in to post on our forums. Signing up is free.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More