Home>Support>Missing Widget

Missing Widget

After the update to pagebuilder >2 we are experiencing problems with our custom widget placed on pages using pagebuilder. Existing pages work well but when we try to create a new page placing a plugin that works well on one page onto the new page using pagebuilder we get the error
‘The widget ‘widgetname’ is not available. Please try locate and install the missing plugin.’
as soon as we save the draft of the page. Before saving the draft all the widget settings can be configured without any problems but after saving we get the error. Needless to say, that the front page is not showing our widget at all. Our widgets still work well in the wordpress widget areas only pagebuilder pages are affected.
Any idea what might cause this behaviour? Our widget mostly use java script but I don’t think that should be a problem.
Thanks in advance
Kai

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 7 years, 6 months ago Andrew Misplon Hi, I Work Here

    Hi Kai

    Sorry to hear about the hassle. I’ll ask Greg if he can jump in here when he has a moment. He’s travelling at the moment so it might take a day or so.

  2. 7 years, 6 months ago Kai Nicolai

    Hi,
    Thanks a lot. It is probably just a small issue but currently I don’t know where to start troubleshooting.
    Kai

  3. 7 years, 6 months ago Kai Nicolai

    Hi again,
    I just updated to pagebuilder 2.06 – unfortnuately the problem persists. We thought the problem was related to our widget not correctly initializing the default culture settings correctly. I remember old versions of pagebuilder automatically opened up the widget option dialog so the site admin had to enter the options at least once. In the new version of pagebuilder the site admin explicitly has to click on “Edit” before the options page is being opened. Is this behaviour intended? But after corerctly setting default values in our widget we still get the “Missing Widget” Error. Unfortunately there are no entries in the error log to work with…
    Any ideas?
    Kai

  4. 7 years, 6 months ago Daniel Hi, I Work Here

    Hi Kai,

    I apologise for the delayed response.

    Could you please try deactivating all plugins that you currently have other than the recommended plugins that we have. After you do this test to see if the issue persists. Since you say your widget uses javascript, you could send me a snapshot of your console incase any javascript errors appear here.This will help us debug the issue.

    Please let me know how you go.

    Thank you.

  5. 7 years, 5 months ago Kai Nicolai

    Hi,
    Sorry I did not mention it but this is always one of the first things I try when widgets are not working anymore, so no, deactivating all other plugins did not do the trick. The javascript console is not to helpful either, I can see no relevant errors. Again, when I pull the widget into a pagebuilder cell it works well, I can edit all the settings which still persist if I hit the Edit button once more – but as soon as I save or update the page I get the Missing Widget error. I can’t post screenshots here, if you give me an e-mail address I could send you a mail including sceenshots and also append the log from the javascript console as well. Alternatively I could setup a wordpress installation with our widget giving you access rights.
    Greetz
    Kai

  6. 7 years, 4 months ago Kai Nicolai

    Any news? It’s still not working :-(

  7. 7 years, 4 months ago Greg Priday Hi, I Work Here

    Hi Kai

    Is your widget by any chance namespaced? We recently added a fix to Page Builder 2.1, which we’ll be releasing soon, that fixes support for namespaced widgets.

    https://github.com/siteorigin/siteorigin-panels/tree/release/2.1

  8. 7 years, 4 months ago Kai Nicolai

    Hi,
    Yes the widget is namespaced, good to hear the issue will be fixed in the next release. Is there any scheduled release date available yet?
    Greetz
    Kai

  9. 7 years, 4 months ago Greg Priday Hi, I Work Here

    Hi Kai

    We’re currently testing and refining this release. So hopefully very soon.

  10. 7 years, 4 months ago Kai Nicolai

    Version 2.1 fixed this issue for me. Thanks guys, thread can be marked as resolved.
    Greetz
    Kai

  11. 7 years, 4 months ago Greg Priday Hi, I Work Here

    Very glad to hear it :)

  12. 5 years, 10 months ago Web Skill Master

    Hi friends
    i am still struggling from this issue. I get following Page not found 404 error while visiting on github.

    https://github.com/siteorigin/siteorigin-panels/tree/release/2.1

    • 5 years, 10 months ago Greg Priday Hi, I Work Here

      Hi Web Skill Master

      We’d like to help you, but can you please start a new thread with your question? We can only offer you the best support possible when you’re the owner of a thread.

      Page: New Thread

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More