Home>Support>Error with SiteOrigin CSS

Error with SiteOrigin CSS

I have siteorigin CSS plugin loaded. When i try to run i get an error:

…wp-contentpluginsso-css/lang/so-css-en_US.mo) is not within the allowed path(s)
…wp-includesl10n.php on line 649

I extracted full path and put in .…
The same plugin runs fine on another machine. The error prints out at the top of the page. Have tried everything I can think of to resolve.

Any ideas?

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 3 months, 4 days ago Andrew Misplon Hi, I Work Here

    Hi Monty

    Thanks for reaching out.

    Do you know which plugin is adding the .mo file? As far as I’m aware, the file mentioned isn’t present by default. Does the issue persist if you reinstall SiteOrigin CSS?

  2. 3 months, 4 days ago monty alger

    The error I get says .mo file not in path. It is the site css plugin. When I deactivate error disappears. When I activate throws the error

  3. 3 months, 3 days ago Andrew Misplon Hi, I Work Here

    Hi Monty

    You can view the SiteOrigin CSS lang folder on WordPress.org: https://plugins.trac.wordpress.org/browser/so-css/trunk/lang. The only file shipped with the plugin is the .pot file. Please, try the following:

    1. Try deactivating and deleting SiteOrigin CSS. Once deleted, go to PluginsAdd New, search for and install SiteOrigin CSS.

    2. If the issue re-appears, please try temporarily deactivating all plugins except for SiteOrigin CSS, does the issue persist in this state?

  4. 3 months, 3 days ago monty alger

    When I activate css plugin get the following. I deactivated all other plugins. Then when I activate only css I get below again. Thanks

    Warning: is_readable(): open_basedir restriction in effect. File(D:\InetPub\vhosts\montyalger.com\montyalger.com/wp-content/plugins/D:\InetPub\vhosts\montyalger.com\montyalger.com\wp-content\plugins\so-css/lang/so-css-en_US.mo) is not within the allowed path(s): (D:/InetPub/vhosts/montyalger.com\;C:\Windows\Temp\) in D:\InetPub\vhosts\montyalger.com\montyalger.com\wp-includes\l10n.php on line 649

    Warning: Cannot modify header information – headers already sent by (output started at D:\InetPub\vhosts\montyalger.com\montyalger.com\wp-includes\l10n.php:649) in D:\InetPub\vhosts\montyalger.com\montyalger.com\wp-admin\includes\misc.php on line 1196

  5. 3 months, 3 days ago Andrew Misplon Hi, I Work Here

    WordPress translations for SiteOrigin CSS are stored at: /wp-content/languages/plugins/so-css/, not at the URL that’s being flagged in the warning.

    Do you have a translation plugin like Loco Translate installed?

  6. 3 months, 3 days ago monty alger

    These are plugins installed. Do you want a temp admin password. Nothing secret on the site. Tks

  7. 3 months, 3 days ago monty alger

    Should also add when I activate capability manager also get an error. So I deactivated that too.

  8. 3 months, 3 days ago Andrew Misplon Hi, I Work Here

    We’re, unfortunately, unable to provide direct assistance (logged in) within our free support scope. We’d love to do more within our free support scope but are limited by resources.

    A list of plugins didn’t arrive in the message, the forum doesn’t support images due to spam problems.

    Please, can you confirm that you’ve tried deleting and re-installing SiteOrigin CSS? It isn’t clear whether that step has been taken. (“When I activate css plugin get the following.”)

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More