Home>Support>Debug log with php 8 and PageBuilder with Vantage Theme

Debug log with php 8 and PageBuilder with Vantage Theme

By HummerBrother, 8 months ago. Last reply by Alex S, 8 months ago.

This is what I get as an error in the debug log when I switch to php 8.0 from 7.4

[29-Jan-2021 17:53:38 UTC] PHP Deprecated: Required parameter $theme follows optional parameter $settings in /var/www/vhosts/DOMAIN/httpdocs/wp-content/themes/vantage/inc/customizer/customizer.php on line 330
[29-Jan-2021 17:53:38 UTC] PHP Deprecated: Required parameter $instance follows optional parameter $errors in /var/www/vhosts/domain/httpdocs/wp-content/plugins/so-widgets-bundle/widgets/contact/contact.php on line 916
[29-Jan-2021 17:55:06 UTC] PHP Deprecated: Required parameter $theme follows optional parameter $settings in /var/www/vhosts/domain/httpdocs/wp-content/themes/vantage/inc/customizer/customizer.php on line 330
[29-Jan-2021 17:55:06 UTC] PHP Deprecated: Required parameter $instance follows optional parameter $errors in /var/www/vhosts/domain/httpdocs/wp-content/plugins/so-widgets-bundle/widgets/contact/contact.php on line 916
[29-Jan-2021 17:55:08 UTC] PHP Deprecated: Required parameter $sub_selector follows optional parameter $ri in /var/www/vhosts/domain/httpdocs/wp-content/plugins/siteorigin-panels/inc/css-builder.php on line 157
[29-Jan-2021 17:55:08 UTC] PHP Deprecated: Required parameter $theme follows optional parameter $settings in /var/www/vhosts/domain/httpdocs/wp-content/themes/vantage/inc/customizer/customizer.php on line 330
[29-Jan-2021 17:55:08 UTC] PHP Deprecated: Required parameter $instance follows optional parameter $errors in /var/www/vhosts/domain/httpdocs/wp-content/plugins/so-widgets-bundle/widgets/contact/contact.php on line 916

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 8 months, 23 days ago Alex S Hi, I Work Here

    Hi,

    Thank you for reporting this. I’ve logged the Vantage related lines with the rest of the team, and they will be resolved in an upcoming Vantage update. The SiteOrign Widgets Bundle and SiteOrign Page Builder related lines are known and slated to be fixed in the next SiteOrigin Widgets Bundle and SiteOrign Page Builder updates. These notices won’t result in any stability errors, but if you have WP_DEBUG enabled (and WP_DEBUG_DISPLAY) consider disabling it to prevent this notice from appearing on the frontend – this can be done by editing your wp-config.php file.

    Kind regards,
    Alex

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More