Home>Support>can’t turn on SiteOrigin Widgets

can’t turn on SiteOrigin Widgets

Hi all,
In WordPress admin, when I go to plugins>SiteOrigin widgets, and I click the switch on the widgets to ‘on’, then go to a page and try to place a SiteOrigin widget in Page Builder the SiteOrigin widgets are not available. When I return to plugins>SiteOrigin widgets, the widgets’ switches are back in the ‘off’ position.

I’m running a prophoto theme…perhaps that is the issue? The basic WP widgets seem to work fine in Page Builder.

Thanks in advance for any suggestions!

Jim

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 7 years, 6 months ago Greg Priday Hi, I Work Here

    Hi Jim

    Are you getting any Javascript errors when you try to activate the widgets?

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors#Step_3:_Diagnosis

  2. 7 years, 6 months ago Jim Gates

    Thanks for getting back to me.
    I don’t think so…I’ve never used firefox’s web developer tools, but followed the steps in the link you provided, and I’ve now tried different browsers and have enabled script debugging in the wp-config.php. When I activate/deactivate the plugins, no message came up under Firefox>developer tools>console
    The the developer tools>error consule appears to have been replaced.

    any other suggestions would be appreciated. I love what Page Builder does – hopefully I can get it integrated!

  3. 7 years, 6 months ago Andrew Misplon Hi, I Work Here

    Hi Jim

    Thanks for the effort. If you have a moment would you mind also switching over to another theme and see if the Plugins > SiteOrigin Widgets settings are able to hold there. That will tell us if this is a clash between the plugin and ProPhoto or if perhaps something else in your installation is clashing.

  4. 7 years, 6 months ago Jim Gates

    Hi Andrew,

    I switched themes and the SiteOrigin widgets stayed on. funny thing is, when I switched back to prophoto5 (with the widgets already enabled) the widgets stayed on! Seems to be working…
    Also, I’m discovering a bit of a 3 way clash – the prophoto button issue I have in the page/post editor, only appears when I have the Page Builder plugin and the Black Studio TinyMCE Widget (Adds a WYSIWYG widget based on the standard TinyMCE WordPress visual editor.) plugin activated at the same time.
    Perhaps an easy fix would be to find a WYSIWYG widget that is more compatible with Page Builder?
    Is this something I could hire someone (like yourself) to go into the back end and tweak the code? Or if the widgets are incompatible am I better off starting over and finding other widgets?
    Thanks again for your help!
    Jim

  5. 7 years, 6 months ago Andrew Misplon Hi, I Work Here

    To break my reply up into points:

    1. Sorry if I missed this point but can you please explain what the ProPhoto button issue is that you have in the page/post editor?

    2. Black Studio is our go to Visual Editor for Page Builder, I don’t know that we have another one right to suggest.

    3. Do you think you could send a set of temporary login details to [email protected] so Greg could take a look. We have seen theme clashes before, sometimes we’re able to suggest a fix that the theme author could make so that would be first prize here.

  6. 7 years, 6 months ago Jim Gates

    Hi Andrew,

    I’ll send the login details, and I also have a screenshot that shows the button issue.

    Thanks,

    Jim

  7. 7 years, 6 months ago Andrew Misplon Hi, I Work Here

    Super, thanks Jim. Please can you also put a link to this thread in the email. I forgot to mention that. Just helps me link everything up on that side.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More