Home>Support>Slow loading; Is “…admin-ajax.php?action=siteorigin_panels_post_css…” a problem ?

Slow loading; Is “…admin-ajax.php?action=siteorigin_panels_post_css…” a problem ?

By Glenn L. McGrath, 7 years ago. Last reply by rootcrop, 6 years ago.

Hi;
I am working on my first website (since plain html was a trend), im using Vantage and pagebuilder, i am experiencing slow load times and am wondering of pagebuilder is part of the problem.
It was taking 17 seconds to load. I tried all sorts of speed/caching plugins to improve it, managed to get it down to 10s, still a lot slower than people expect.
Currently I have disabled all plugins except pagebuild and metaslider and it is 8.5s
I have been testing it at pingdom, and gtmetrix eg;
http://tools.pingdom.com/fpt/#!/er62LD/http://www.laborsouthwest.org/
http://gtmetrix.com/reports/www.laborsouthwest.org/kbcjGB19
It seems i have two calls to “siteorigin_panels_post_css” which take 4 to 5 seconds, and looks to me to be one of the main things slowing it down.
The two calls look like
…/wp-admin/admin-ajax.php?action=siteorigin_panels_post_css&post=156&layout=855616d7&ver=1.5.3
…/wp-admin/admin-ajax.php?action=siteorigin_panels_post_css&post=home&layout=855616d7&ver=1.5.3
CPU usage on my host seems to be faily high just with me testing it and no other users, could it be my host ?
YSlow also gives me a bad score for not using “cookie free domains”, i am using cloudflare as a cdn, and i am also wonderign if that could be it.
Should pagebuilder be causing 4-5s wait times, am i doing something obviously wrong ?
Any pointer aprpreciated, thx

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 7 years, 3 months ago Andrew Misplon Hi, I Work Here

    Hi Glenn

    The next version of Page Builder will have a checkbox under Settings > SiteOrigin Page Builder to activate Inline CSS. Should be out this week. Once you see the upgrade, run it and check this setting. Let us know how things look after that.

  2. 7 years, 3 months ago jtc.customs

    Came here to post the exact same thing. The issue is not isolated to just OP.

    The last page builder update killed my site loading speeds. These two 700 B files take 2 seconds to load or more for me at all times. I’ve done 30+ tests in the past few days and I always get the same results.

    Thank you for letting us know there is a solution coming!

  3. 7 years, 3 months ago Glenn L. McGrath

    Thanks Andrew, really apprecaite the response.

  4. 7 years, 3 months ago Andrew Misplon Hi, I Work Here

    Thanks for the added report there jtc.

    For sure Glenn.

    Guys, let’s chat again once this next Page Builder update gets pushed (soon) and we’ll hopefully see a better situation.

    Thanks for the wait.

  5. 7 years, 2 months ago Steven Meyers

    I would like to say Thank you for the get plugin.

    This topic issue is a serious trouble for me, my websites are not workable any longer due this issue and Woocommerce has their own conflict with admin-ajax.php.
    Is there any hope to get the update within the next week or it would be faster to rebuild my Wp template based on any other temporary solution?

    Any temporary solutions workable with the latest WP version?

    Thank you.

  6. 7 years, 2 months ago Andrew Misplon Hi, I Work Here

    Hi Glenn and Steven

    Here is the new version of Page Builder that needs to be pushed live: https://siteorigin.com/wp-content/uploads/2014/10/siteorigin-panels.1.5.4.zip. You can manually update by deleting Page Builder and then installing the new ZIP from Plugins > Add New: Upload Plugin. Once installed head to Settings > SiteOrigin Page Builder and activate Inline CSS. Let us know if that helps.

  7. 7 years, 2 months ago Steven Meyers

    Hello,
    I just tested ver.1.5.4 on http://tools.pingdom.com/ and admin-ajax.php?action=siteorigin_paneā€¦

    showed 8.37 sec.

    Without Page Builder this file is not being loaded at all.

    Woocommerce plugin does the same thing and both plugins are on they double their effect on each other and on the rest of files slowing down the page loading time up to 40-50sec all together!

    Also I have noticed that some of Themeforest premium class website authors have resolved this problem I have send the question to one of them, will let ypu know if responded. They have Woocommerce and one page parallax heavy code and a page with tons of content is loading 4-5 sec.

    Kind Regards,
    Steven

  8. 7 years, 2 months ago Andrew Misplon Hi, I Work Here

    Hi Steven

    Did you try 1.5.6 in conjunction with activating Inline CSS?

  9. 7 years, 2 months ago Glenn L. McGrath

    I am showing significant imporvment, 4s load time now, i did active the inline CDD is sitorigin settings.

  10. 7 years, 2 months ago Glenn L. McGrath

    (I activated the inline CSS in the siteorigin settings, note to self look while type)

  11. 7 years, 2 months ago Steven Meyers

    Hello Andrew ,
    On the site https://siteorigin.com/page-builder/ thwre is Version 1.5.3
    And you have posted link to version 1.5.4

    Where could I get the 1.5.6?

  12. 7 years, 2 months ago Glenn L. McGrath

    Stephen i think it must have been a typo, the Inline CSS option he is refering to is under Settings->Site Orginin Page Builder-> Inline CSS (tick it).

    My page load speed is 7.4 s without it ticked and 3.9 with it ticked.

    I didnt try inlining with any other 3rd party tools.

    Thanks Andrew, well done.

  13. 7 years, 2 months ago Steven Meyers

    Version 1.5.4 + inline CSS did that trick!

    Thank You Andrew for your great work!!!

  14. 7 years, 2 months ago jtc.customs

    images speak louder than words. Thank you Andrew!

    http://www.georgiaodyssey.org/wp-content/uploads/2014/10/speed-difference.jpg

    (when I add an img tag my post will not go through.. hopefully no html coding will allow it to work even if you guys have to copy paste the link)

  15. 7 years, 2 months ago Andrew Misplon Hi, I Work Here

    Sorry for the delay here gentleman! Thanks very much for everyone’s support, testing efforts and data feedback here, it is most appreciated by Greg and myself. Glad to hear the update has moved things back to normal.

  16. 7 years, 2 months ago Firstname Lastname

    This exact issue is destroying my website load times as noted in webpagetest waterfall results. If I delete the plugin and install the updated one, will I permanently lose all the Page Builder layout work I did in all my pages? If so, will you be pushing the 1.5.4 update soon to WordPress?

    Thanks.

  17. 7 years, 1 month ago Firstname Lastname

    Page Builder 1.5.4 was released to the public this morning and has fixed this issue for me. The ajax.php call is gone and I am seeing a massive increase in my page load speeds; speed is now comparable to when I built the same website previously using RVSiteBuilder.

    • 7 years, 1 month ago Greg Priday Hi, I Work Here

      Glad to hear it fixes the issue for you :)

  18. 6 years, 5 months ago Semper Aye

    I think this the same issue I’m having with vantage and my admin, can’t wait to try the fix if it’s still relevant….

    • 6 years, 5 months ago Greg Priday Hi, I Work Here

      Hi Semper

      This issue has been resolved for quite some time now. If you’re using the latest version of Page Builder and you’re still getting issues, please feel free to start a new thread and we’ll help you there.

      Page: New Thread

      If you’re a premium user, please be sure to enter your order number so we can properly prioritize your thread.

  19. 6 years, 1 month ago rootcrop

    wp plugins: Heartbeat Control or
    AJAX Heartbeat Tool

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More