Home>Support>PageBuilder breaks editing of WooCommerce coupons

PageBuilder breaks editing of WooCommerce coupons

I recently discovered that some parts of WooCommerce and PageBuilder (both using the latest versions) do not play nicely together. If you have both plugins installed and go to set Usage Restrictions on a WooCommerce coupon, you are unable to enter values for any of the text fields. There is also a PageBuilder window underneath the Coupons editing panel that should not be there, I think.
To be able to setup restrictions on coupons, you need to first disable PageBuilder, then go in and enter values to the fields, then re-activate PageBuilder. Obviously on a live site this is not an ideal solution. Any chance someone could fix it for an upcoming version please?
Thanks!

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 5 years, 8 months ago Greg Priday Hi, I Work Here

    I recently came across this issue. It seems like there’s a really easy fix.

    If you navigate to Settings > Page Builder, in your WordPress admin, you should see a Post Types setting. Which options are checked there? Can you try unchecking any WooCommerce related items if any are selected.

  2. 5 years, 8 months ago Jo Batkin

    Perfect, I unticked the box for Coupons and now it works perfectly. Phew, thanks for an easy fix!

  3. 5 years, 8 months ago Greg Priday Hi, I Work Here

    I’ll hard code a fix into the next update of Page Builder. Glad to hear this fixed things for you!

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More