Home>Support>How to change meta description for home page

How to change meta description for home page

By Tina Spruk, 4 years ago. Last reply by Andrew Misplon, 4 years ago.

Like the title sudgest how do i change meta description for home page when i checked my webite on google search my meta description was taken from the first Circle icon widget how do i add my own meta description for the first main page?

This is our free support forum. Replies can take several days. If you need fast email support, please purchase a SiteOrigin Premium license.

  1. 4 years, 11 months ago Andrew Misplon Hi, I Work Here

    Hi Tina

    The easiest solution is to install the awesome WordPress SEO plugin by Yoast. Once installed click on SEO > Titles and Meta > Home and edit your home page meta data there.

    http://wordpress.org/plugins/wordpress-seo/

  2. 4 years, 11 months ago Tina Spruk

    Thank you i installed it and changed it’s “Meta description template:” in tab “Homepage” .
    Do you know how long will it take for google or other browsers to update the description?

    again thank you for your help

  3. 4 years, 11 months ago Andrew Misplon Hi, I Work Here

    No problem, glad you sorted it out. I can’t say when your site will next be crawled. To help it along also sign up for Google Webmaster Tools. You can enter your Webmaster ID into WordPress SEO to handle the site verification.

  4. 4 years, 11 months ago Tina Spruk

    Again thank you :D

  5. 4 years, 7 months ago Julien Jégard

    hi
    i just bought vantage and installed it on http://www.pokerbastards.com and I have the same issue wiht meta description but I can not change meta with wordpress SEO because SEO options/fields are not available for pages (tab does not show!).
    It looks like there is a issue but i don’t understand from where. I have desactivated all plugin and activated them again one by one.

    Any help would be appreciated.

    thank you

    • 4 years, 7 months ago Andrew Misplon Hi, I Work Here

      Hi Julien

      On any given page click the Screen Options drop down top right and ensure that WordPress SEO is checked.

      Hope that helps. For further assistance please open a new support thread for us.

      Thanks

  6. 4 years, 7 months ago Julien Jégard

    thank you for you anwser.
    unfortunatly there is NO wordpress SEO option in this screen option. I see it on articles but not on pages. It makes me crazy.

  7. 4 years, 7 months ago Andrew Misplon Hi, I Work Here

    It should be there. I’m not sure what else to try here. Some standard troubleshooting steps would be to:

    Dashboard > Updates, update everything that has a pending update.
    Disable all plugins besides Yoast and re-check.
    Change to a default WordPress theme like Twenty Fourteen and re-check.

    If you have no luck with the above it would be best to open a forum topic on the WordPress SEO plugin page, hopefully they’ll be able to assist further.

Replies on this thread are closed. Please create a new thread if you have a question, or purchase a SiteOrigin Premium license if you need one-on-one email support.

Get The Most Out of SiteOrigin with SiteOrigin Premium

Find Out More